Wpdatatables not showing in Sydney pro

Hi

Im using a plugin called wpdatatables, the pro version.

Im using Sydney Pro now but created tables before I updated to pro. After created a child theme and then upgrading to pro my tables dont show any more.

Ive tried to insert them i a newly created page with same result, they dont show.

www.webetyouwin.com/results

Any ideas

Hello there,

Please share the download link of the free table plugin, so I can try it on my test site.

Regards,
Kharis

Hello there,

I am sorry, I can’t compose a new table. Whenever I hit the save button, I am always getting this message:

Sorry, this function is available only in FULL version of wpDataTables along with many others!

I am even with default settings. This situation prevents me to do testing.

I visited the link you initially shared, it looks like the table is displaying fine in there.

Cloudup

Have you been able to resolve it?

Regards,
Kharis

Hi Kharis,

No its not the correct tables Im afraid. These have been created in other plugin and in wpdatatable wizard. The tables I created in the past still doesn’t show.

There seems to be some compatibility issue, some Js conflict

Investigating but its a struggle

Hello there,

Would you mind allowing me to access your admin area? If possible, please share me the login credentials to your site admin (/wp-admin) and point me to the location/menu where you created your table and the page URL you inserted it into. Please send those details to my email, kharisblank@gmail.com, and include the link to this topic in your message body.

Regards,
Kharis

Hi Kharis,

Sent mail to developers of the plugins since its their job to solve it for me I would assume.

This is what I wrote them, feel free to figure out the custom CSS for me if you can figure it out :slight_smile:

The reason that the tables are not showing is because “Hide table until page is completely loaded” is checked. I unchecked this and the tables show. However, they dont look like they used to but rather a formated version. No color, no hoover etc.

Even if I change color and such in “Settings” it wont apply.

So to solve this temporary I would use the Custom CSS to the following:

Header background color

Header font color

Hoover row color

Also would need the other “standards” that used when creating a table. The 3 things above is the only things I changed in settings so also need the default settings in custom css.

This is how it used to look

This is how it looks now

Again this is just a temporary issue since I need my tables to look attractive so please provide me with this as soon as you can

Best regards

Hello there,

To style your table to look your screenshot, you’ll need a couple of extra CSS code. Add this into Appearance > Customize > Additional CSS in your site dashboard.


table thead tr {
  color: #419639;
  background-color: rgba(0,0,0,0.9);
}

table tbody tr:nth-child(odd) {
  background-color: #f7f7f7;
}

table tbody tr:hover {
  background-color: #e4e4e4;
}

Regards,
Kharis

Hi Kharis,

Thank you so much, worked like a charm.

Best regards

You’re welcome!

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis