Wordpress 5 Compatibility


#1

Hi there, I just updated my Wordpress to version 5 - but now have to rollback to a previous version, The back end (building and editing posts) does not work as it does not display any content.

Is there a planned update in place - otherwise I have to rebuild my website from the ground up soon.

Thank you,


#2

Hello there,

We’ve just updated our Sydney theme a couple of moments ago to address Gutenberg editor compatibility. Are you running the latest version?

To check if it’s an issue with the theme’s code, please try temporarily disable all your active plugins (except the required ones), then run your test.

Regards,
Kharis


#3

Hi, I just have the same problem. Wordpress works as a multisite. Interesting because the problem I have with the main site and with the other two is everything OK. I can edit pages and posts, SiteOrgin works normally. The problem is only with the main site. Disabling and re-enabling plugins did not help. It looks as if everything is not updated.

Regards
Andy


#4

Hello Andy,

As the issue is inconsistent, there might be an issue with the core code of WordPress editor. At the mean time, I can only suggest you use classic editor by enabling with this plugin: https://wordpress.org/plugins/classic-editor/, instead of rollback the WP version.

Regards,
Kharis


#5

Hello Kharis,

Hey. Thank you for the quick reply. I’ve installed this plugin early but it will not help.
Is it possible to fix it or rather return to the older version of the WP? How long does Sydney update?

Regards
Andy


#6

Hello Andy,

The latest version is now 1.53 with Gutenberg support added.

https://athemes.com/changelog/sydney/

Please check your current version, might be updating it would fix the issue.

Regards,
Kharis


#7

Hello Kharis

I have the latest version of Sydney 1.53 installed.
I think I installed the new WP version too soon or something went wrong.
Generally, I have a problem with the fact that I do not see pages to edit and some translations have disappeared.

Regards
Andy


#8

This is really out of the scope of theme’s code. Maybe the translation plugin hasn’t yet been ready for Gutenberg? You might need to consult with the plugin’s author.

At the mean time you could downgrade your WordPress system with the below plugin, of course, if you want to.

Regards,
Kharis


#9

Hi,

It helped but restore files and database.
Probably some plugin is not well adapted to 5.0. I will wait about a month with upgrade to 5.0. Thank you for your help.

Regards
Andy


#10

Hi,
The worst thing is that WP itself updates itself to 5.0.
Can I turn it off?
Regards
Andy


#11

Hello there,

By default WordPress 5.0 will not auto-update. Refer to this thread: https://wordpress.org/support/topic/will-wordpress-5-0-update-automatically/#post-10948393

However if it still does on your own, probably you’ll need to manually disable it. Read this article that will tell you how to do so in “How to Disable Automatic Updates the Easy Way – A Plugin” section.

Regards,
Kharis


#12

Hello,
THX.

My WP is 4.9.8 and this version automatically updates to 5.0. I checked and the SiteOrgin plugin interferes most. But only when WP updates to 5.0. I’ve installed the EUM before and I’m waiting for the plugins to work properly. Thanks for the help.

The most important: BACKUP FILES.

Regards
Andy