Wordpress 5.0 for Ignis Pro Theme

I have Ignis Pro and was wondering if it is ok to update that theme to Wordpress 5.0?

Hello there,

Yes, it’s okay. WP 5.0 updated the editor to become more modern, that might be a bit complicated for the first time. You might want to study it in this documentation. To use older editor, you can enable this plugin:

Regards,
Kharis