Woocommerce images

When i add multiple product images to a product then the images that are displayed are the thumbnail images. When you click on the image then you see the right image.

https://wordpress.hum-ble.nl/product/legging-dots/

Hello there,

It isn’t an issue with the theme. That’s the default behavior of WooCommerce system. If you want to change it, you should consult to WooCommerce support https://wordpress.org/support/plugin/woocommerce

Regards,
Kharis

Ok. but why does your demo does it right?

http://demo.athemes.com/themes/?theme=Leto
Home / Clothing / Hoodies / Ninja Silhouette

Hello there,

Sorry, I didn’t notice any difference in this product http://demo.athemes.com/leto/product/ninja-silhouette-2/

Maybe I couldn’t exactly get the issue you’ve explained.

Regards,
Kharis

View the printscreen. On your demo website it works correct.

On my test website the thumbnail is loading in the “slick-slide”

https://wordpress.hum-ble.nl/product/legging-fox/

Hello there,

Does it only happen with that product? Try deleting its featured image and associated gallery image, then try to re-set them all.

Let me know how it goes.

Regards,
Kharis

It’s happen with al the products. If I open devtools then I see that the loadig <img width=“100” height=“100” src=“https://wordpress.hum-ble.nl/wp-content/uploads/2017/11/hmprod-12-100x100.jpg

on your page it is

<img width=“600” height=“600” src=“http://demo.athemes.com/leto/wp-content/uploads/sites/68/2017/11/hmprod-1-1-600x600.jpg

I removed the images from the product and regerates the images. Problem still exist.

I am also having this problem - i have tried setting the thumbnail image width as advised after a Google.

But it appears that thats its a problem with your theme. As in your demo product product images are bigger than the gallery images. You can see what i mean here by visiting this page and selecting the second image - you will see that its small. https://florencesboutique.co.uk/?product=patient-ninja

Hello all,

From your site dashboard, visit Appearance > Customize > WooCommerce > Product Images. Enter 600 for “Main image width” and 300 for “Thumbnail width”.

Regards,
Kharis

The settings are 600 for Main image, 300 for Thumbnail and custom 4:3.

This also doesn’t help.

Hello there,

You might need to regenerate uploaded images with the new size specified with this plugin: https://wordpress.org/plugins/regenerate-thumbnails/

Regards,
Kharis

Sorry that also didn’t work. I also installed a new test website with the demo content of the theme. The same issue.

leto.hum-ble.nl

Do you have an update on my problem?

Hello there,

Please try switching to the default WordPress theme temporarily and see if it resolves the issue. This procedure will help you diagnose whether Leto really produces this gallery size issue.

Regards,
Kharis

No problems with the default theme Twenty Seventeen

https://wordpress.hum-ble.nl/product/shirt-dots/