Woocomerce 3.0.0. and the shop

hello,

After update`te to woocomeerce 3.0.0. some features of “the shop” are down.
Product gallery doesn’t work anymore
and the galley on the home page is down.
Furthermore there some small errors

Will there be a fix ?

Hi,

What other small errors are you referring to please?

Have the same question.

After WooCommerce update the most common mistake is that front page permanently reloads. It effects all the links - simply you do not have a chance to click it to move forward.

I am very happy with TheShop, this is why it would be very nice if you will release a small update to resolve and fix some errors raising after update.

I’d like to see a link to your page please so I can see the loading error you mentioned, I can’t seem to reproduce it.

Thanks for your prompt reply

This is probably caused by the security plugin you’re using as far as I can see.

These are the issues I found and fixed. If you guys are seeing other issues that I’m missing, please let me know:

  • single product gallery broken;
  • single product gallery lightbox missing;
  • font size for product titles on shop archive;

The gallery on the homepage looks fine to me.

most of the plugins incl. Shield were de-activated. Also, de-activated all plugins which not offered update before or after Woo update. Unfortunately no effect.

Try the Woo BRands plugin, I see it’s showing some errors. I’m not sure this is caused by the update to Woocommerce. I suggest you disable all plugins.

Thanks Vlad,

A couple of remarks:

“These are the issues I found and fixed. If you guys are seeing other issues that I’m missing, please let me know:
– single product gallery broken;
– single product gallery lightbox missing;
– font size for product titles on shop archive;”

About the little errors: font (weight) size for related products on productpage is a little strange now.
and the featured products range on the homepage is down.

A strange question maybe, but to update “the shop” download it again and install again?
I 'd like to donate for your edits because i like the shop very much

kin regards.

This is my final decision:

  1. Since all mentioned plugins are deactivated, but there is no change - in case there will be an update fixing all the errors I am ready to donate for this work, as well as I would like to donate for next updates as well.

  2. In case there is no chance to update and fix the theme - I’ll have to switch to another theme…

Unfortunately…

featured products range on the homepage is down

I’m not sure what you mean here, we don’t have a featured products section. All 4 homepage sections seem to work fine. Perhaps share a link to your site.

A notice will show up in your backend once the update is available.
We don’t take donations. If you want, you can buy the footer credits extension.

@alex.chirovici@gmail.com: I think you should try now and switch to another theme and see if the issue is fixed. Do you have code changes to the theme?

Vlad, this is not a big problem to keep info about theme developer in the footer. I am not programmer or site developer - I am a businessman who decided to launch a site without paying someone :slight_smile: That’s why I believe it is a kind of respect if you promote the guys who developed the theme.

Website: https://tinyurl.com/n4vautg

Vlad: "featured products range on the homepage is down
I’m not sure what you mean here, we don’t have a featured products section. All 4 homepage sections seem to work fine. Perhaps share a link to your site."
I mean exactly latest products is down. the first option in the editor. At the moment i put it down because if its on it might give errors i don’t see.

Vlad "We don’t take donations. If you want, you can buy the footer credits extension."
Already bought that

@Peter460: I’m confused. Is it broken or did you disable it? On my test site it works fine.

@alex.chirovici@gmail.com: you might want to see this, I think this is your problem https://wordpress.org/support/topic/3-0-frontend-pages-refreshing/

@vlad i did disable it because it doesn’t work anymore. (immediatly after woo commerce 3.0.0 update)

@Peter460: Well, re-enable it for a bit so I can see what’s going on. As I said, it works fine for me but they made such a big mess with this new Woocommerce update that anything is possible.

@vlad i turned it on and IT DOES WORK. i think it was a caching problem straight after update