Where to disable sticky menu for page?


#1

Hi,

I’d like to disable the sticky menu on the page https://michaelwijnands.nl/amida/reparatie/.

Basically I want the page to be the same as https://michaelwijnands.nl/amida/onderhoud/.

Where can I disable the sticky menu? It just needs to be static.

Regards,

Michael


#2

If you are trying to completely hide the menu go onto plugins, add new and search for ‘Exclude Pages From Menu’ on ‘Pages’ on wordpress you can disable any page you want from showing up on the menu using this plugin.

The way you have it now on https://michaelwijnands.nl/amida/reparatie/ will not work for google, they will not be happy when they see you trying to hide text by making it the same color as the background color and you will get punished for trying to cheat the system in what’s known as ‘Black hat’ SEO tactics.

If you are trying to change the way the menu works you can go onto the appearance tab and change it in the header section from sticky to static and back. I don’t believe you can have it sticky on some pages and static on others…


#3

Well I just want it to be like the other pages. I got one of them from the demo but when copying it, saving it as template and using it again the menu doesn’t behave the way I want it to.

I’m not trying to cheat on Google or something like that.


#4

Hello,

Try to select Static menu option in Customize → Header → Menu section.

Please feel free to ask any other questions that you might have.

Kind Regards, Roman.


#5

EDIT: finally got it to work after creating the page again. Is there a possibility to have an active menu item (the page you’re currently on) to have a different color in the menu?

Hi,

No that didn’t help. It seems that the page “reparatie” seems to ignore the settings.
I did set a custom CSS which should make the menu gray instead of transparent (just like on the other pages except home), but it doesn’t work and keeps being transparent.
The menu should have the same gray color when you scroll down and it gets sticky.

And yes, the gray colors are set at Customize > Colors > Header.

To me it starts to look like the theme is broken: ignoring settings doesn’t seem good to me. I just want to get the 'reparatie" page the same as every other page (except home). Why can all the pages be that way but doesn’t the reparatie page want to cooperate?


#6

Yes Michael, try to use the following CSS code to change current menu item color.

You can add CSS code in Customize → Additional CSS section.

.main-navigation .menu .current_page_item a {
    color: red;
}

Kind Regards, Roman.