Website hanging on 'Moment please' after latest WordPress update

I’ve just upgraded our test environment to WordPress 4.9.4. Now the website is hanging on the blank screen with ‘Moment please’ message. I’ve tried disabling all plugins, same result. Changing to another theme solves the problem. So this leads me to believe that it is a combination of our TheShop theme (free version) and the latest WordPress upgrade.

Anybody else have this problem?

Hello,

I don’t see this issue on my local TheShop install.

Can you please provide a link to your website?

Kind Regards, Roman.

Hi Roman,

Thanks for your reply. The link to my website is http://mankrat.easynow.nl/.

Thanks for any help you can provide as I don’t have a clue. If it works with other themes and disabling all plugins doesn’t help, I’m out of options.

Kind regards, Martijn

Hello Martijn,

As a workaround, you can disable preloader using the following CSS code.

You can add CSS code in Customize → Additional CSS section.

.preloader {
    display: none;
}

Please feel free to ask any other questions that you might have.

Kind Regards, Roman.

Thank you for your workaround Roman. It helps a little, but the site still is not fully functional.

What I have discovered is this: If I restore a recent backup from when the site was fully functional, I can do the following without problems:

  • Upgrade WordPress
  • Upgrade all plugins but WooCommerce

When I upgrade WooCommerce however several problems arise. The frontpage gets stuck on the preloader and adding products to the shopping cart doesn’t work.

Disabling the WooCommerce doesn’t solve the problem either. It seems that the problem lies in the combination of the newest version of WooCommerce and TheShop theme, as switching to another theme (I have tried several) doesn’t produce this problem. I have also tried other hosting providers but the problem persists.

I hope this is of any help to find a solution. Also I cannot imagine that we are the only ones who experience this problem, a lot of websites will probably use the combination of TheShop and WooCommerce.

Thank you for any help you can provide!

Hello Martijn,

I couldn’t recreate your issue on my local TheShop theme install (with WooCommerce).

Please try to deactivate all your plugins except WooCommerce plugin and see if it helps.

Kind Regards, Roman.

So strange, as I have been able to reproduce this issue on my local laptop and two hosting providers.

As indicated disabling all plugins doesn’t solve the issue. In fact once I updated WooCommerce even removing all the plugins completely didn’t solve it. Something seems to happen during the WC upgrade that cannot be undone by disabling or even removing plugins.

I appreciate that not being able to reproduce this issue makes it nearly impossible to assist. However I find myself forced to look at an alternative theme because as I’ve also indicated that with other themes the issue does not seem to occur and I do need a solution for our production environment.

In this complex world sometimes we will never know all the answers.

Yeah Martijn, but you can also try to reinstall TheShop and WooCommerce completely.

Also you can make sure that your hosting environment meets WordPress requirements:
https://wordpress.org/about/requirements/

Kind Regards, Roman.

For future reference and other users: I have performed a rollback (using WP rollback plugin) of WooCommerce to version 3.2.6. It seems that WC 3.3.1 has some issues (found this on several forums). I will wait for a new WC version.

Long live WP rollback and of course backups and first trying updates in a testing environment ;-).

Thank you Roman for your efforts, much appreciated.

Indeed the new WooCommerce upgrade today did solve the issue. It had nothing to do with TheShop theme. Just to be clear ;-).

You are welcome Martijn, and thanks for sharing that info! :slight_smile:

Kind Regards, Roman.