WEB differents Languages -POLYLANG

Hello,

Folowing you documentation for the theme PERTH, I have installed the plugin POLYLANG to have the web in differents languages and I have some questions:

  • From I install this plugin when I put www.littlefaro.com it is become automatically in www.littlefaro.com/fr/home-page/ why? I want that the domain appear normaly…like www.littlefaro.com
  • hOW I can chose the language principal of the web (in french)? I want English version is the secundary language.
  • How I can put the differents flags in the home page to change the language?
  • With this plugin the traductions are automatically or I have to do it manually?
    -When I go to page section in each page appear the option “Upload to Lingotek”, why? for what is useful it? I tis important to do it?

Thanks very much

Virginia

Hello again, did you reveived my msn with the question?
I didnt received the reply yet…
tHANKS VERU MUCuch!
Virginia

Dear Virginia,

I would like to apologize in advance for the delayed respond.

Could you confirm if you have read the plugin’s documentation here?

Regards,
Kharis

Hello, yes I have checked the documentation but I still have the same questions…Could you help me?

1-For example the documentation says this (below) but I dont find the place to add the flags with the differents languages. If I go to Appearance-menu I dont find 'screen option". Why?

I can’t add the language switcher in the menus
In appearance->menus, go in screen options on top right of you screen and check the “Language switcher” checkbox. You then should have a new metabox which allows to add a language switcher just as you add another menu item.

2- Also where I can choose tu put the home page (littlefaro.com) in french version and if it is english version (littlefaro.com/en) ?

thanks !

I relation about the second question I want to mean that why when I put www.littlefaro.com appear the english version when I want the french version (the principal homepage). For the english version I want the followinf link: littlefaro.com/en

It is like the english version appear atuomatly when I am in the home page , why if I have fixe the french version ? (in the pages)

thanks

I think I can find how to show the flags languages but I would like to put the Flags language (language Switcher) at the top of the header photo (where is the MENU), not below. How I do it?

Thanks

Hello there,

Please read the documentation here.

Regards,
Kharis

Thanks Kharis but like I have explained in my last message I have read all documentation and I dont find some options.
For example:

I dont find the screen optionon top right in MENU section. So I dont see the “Language Switcher”. Like the texte before explained…

-I can’t add the language switcher in the menus.In appearance->menus, go in screen options on top right of you screen and check the “Language switcher” checkbox. You then should have a new metabox which allows to add a language switcher just as you add another menu item.

Why I dont see it? I want to add the flags but in the top of the header big image of the homepage (not below this one). It is possible?

thanks!

Othe thing important why my homepage is appear in english version when I have chosed in french version?why my homepage it is automactly in english version?

I want home page www.littlefaro.com : french version
www.littlefar.com/en : english version

Hello there,

I would like to apologize in advance for the delayed respond.

> I dont find the screen optionon top right in MENU section. So I dont see the “Language Switcher”.

Could you confirm if you have created at least one language in Settings > Languages?

> I want to add the flags but in the top of the header big image of the homepage (not below this one). It is possible?

Yes, it is possible. You should insert the following code in the header.php file, immediately after <div class="header-wrap">.


<ul class="language-switcher">
	<?php
	pll_the_languages(array(
		'show_flags' => true,
		'show_names' => false
	));
	?>
</ul>

You should pass it in the child theme mode.

> Othe thing important why my homepage is appear in english version when I have chosed in french version?why my homepage it is automactly in english version?

AFAIK, it depends on the default language of the web browser. The free version of Polylang plugin doesn’t allow us to setup site’s default language.

Regards,
Kharis

Hi I was recently struggling with this:

“why my homepage is automatically in English version?”

Solution on free Polylang plugin+Sydney Pro was to deactivate “Detect Browser Language” from Polylang languages settings on WP dashboard.

Regards
Timba

Hi Timba,

Have you checked your website with different web browsers and/or different network/ISP (internet service provider)? Maybe there is a cache on your ISP.

Regards,
Kharis
aThemes Support