Video Player of Sydney theme

Hi there,

Does anyone happen to know which video player the default video player is? Is it HTML5?

Thanks so much in advance!

Sven

Hi Sven,

Thank you for your question.

Video player is defaulted to WordPress code and it uses both HTML5 and non-HTML5.

To enable HTML5 video, you can use video shortcode. For example:

[video mp4="source.mp4" ogv="source.ogv" webm="source.webm"]

Or use an additional plugin like Html5 Video Player – mp4 player, Video Player for WordPress – WordPress plugin | WordPress.org.

Hope that helps.

Regards,
Kharis
aThemes Support

Hi Kharis,

does this additional HTML5 video Plugin also work with the Sydney Slide Button Lightbox Plugin that you developed a while back? I am wondering if I am able to track the video that I inserted in the plugin you had developed, which only works if the video is hosted on the same server of the website and is in HTML5 format?

I guess you’re referring to this plugin. If so, this shortcode should work with any video URL.

[SydneyVideoButton btn-class="mybutton button btn" url="YOUR_VIDEO_URL" text="Button Text" nonSlide="yes"]

You can replace YOUR_VIDEO_URL with the video URL you have in the media library (Dashboard > Media).

Regards,
Kharis
aThemes Support

Hi Kharis,

Yes, this is the plugin, but I am not sure what you mean.

image

What the plugin does is open the link that I put in the header in a lightbox. You can test what I mean on my website when you click on the button “Video ansehen ►”: Qreativraum - Steigerung der Innovationsperformance

However, is the video player that is opening up HTML5? If not, can this be changed? For example, the plugin you recommended would be me a shortcode like this: [html5_video id=1959]. But copy&pasting this into the header field which says URL is not working.

Hi Kharis,

I did some testing. The default video player from WordPress actually seems to be HTML5. I used following guide to be able to track it: HTML5 Video Tracking Recipe for Google Tag Manager - Analytics Mania

However, the video that is loading in the lightbox is currently not being picked up by the tracking. I did some digging and found out that the Iframe might be causing this issue: How to track iFrames with Google Tag Manager - YouTube

What do you think? The lightbox is still using an HTML5 video player, or? Would it be possible to to get the tracking to work somehow?

Cheers,

Sven

Sorry for confusion. I thought you were using a shortcode to create the button.

Perhaps you’ll need to insert the video in a separate page (without header, sidebar, and footer area by enabling Blank Slate template). And get the link to that page and insert it into the slide button URL box in customizer.

I hope that helps. Let me know your views.

Regards,
Kharis
aThemes Support

You mean so that the seperate URL would load but still keep the lightbox active?

I could try that - one immediate concern would be that if I remove the header and footer, that also means I am removing the tracking code from that page :wink:

So the plugin works fine, but I am not sure it will solve the problem that the plugin uses the Iframe. Eiter way I am pointing to a link from my website. In order to try it I would also need to find a way to apply the JavaScript Code to that page, which that is the only way in which this might be different since it would track specifically this page.

Do you know how I would do that? I could of course buy the pro version - but that’s wuite some money not knowing if that would even work.

Sorry for the many updates - I tried it with a regular page where header is not removed. It’s the Iframe that is causing the problem. Not sure if there is a workaround? Or a different plugin which does not use IFrame?