Video Header just on WelcomePage

Hello,
I have a few questions regarding the video header:

  • How can I have different video-headers on different pages?
  • How can I show the video header JUST on the Welcome Page and the other pages have something different (e.g. Slider) in the Header?
  • How do I adjust the header size for all sides apart from the welcome page?
  • Is it possible to have the video header with activ sound?

Thanks for your help!!

Br,
Lisa

the page I am working on is the following: www.looptheglobe.de

Hello,

Most of these things there aren’t possible with the video header. But you can use the bundled Revolution Slider to achieve everything on your list. And this is way cooler and more flexible than the default video header.

Basically, it would go like this:

  • disable your video header and remove your header image, if if you have any image set. Now, the menu should be at the top of your page on every page.
  • assign the Front Page template for each page that you want a video or a slider in.
  • go to Revolution Slider (if you’ve installed it) and create as many sliders as you need - they don’t actually have to be sliders, they can also contain only one full screen HTML5 video, or Youtube video or a mix between videos and images.
  • build each of those pages with the Page Builder, and place the Revolution Slider widget on a row, then select the slider you want for that page. Do the same for all your pages that need a video or a slider.

Let me know if something doesn’t make sense or if you need help doing this.

Hello,

many thanks to that explanation. That revolution slider is quite new for me so I struggle a bit about the details but I am quite happy with the first result.

One more question poped up in my mind:
How can I minimize the white space between the navigation and the upper/lower edge of the slider? You see it on the webside.

Thank you!

Br,
Lisa

Yeah, it does have a lot of options so it might be a bit hard to work it, but it’s worth playing a bit with it.

You can add this to a custom CSS plugin to remove the padding before and after the slider:


.widget_rev-slider-widget {
    padding: 0 !important;
}

Or you can add this to remove it just from the top:


.widget_rev-slider-widget {
    padding-top: 0 !important;
}

I tried to integrate in the Rev. Slider a MP4-Video. But it just shows as a black screen.
see: www.looptheglobe.de
The video itself can be opened via the browser without problems.

I recon this is probably more a slider issue than a moesia issue, but maybe you also know what to do?!
Thank you!

I’m not seeing the video at the URL you added in Revolution, which would be this: http://www.advakite.com/intro-2-html5.mp4. Not sure what’s happening, but I tried Revolution with a mp4 video and it’s working properly, so please check your settings again.

The link is with a big “I” like this: www.advakite.com/Intro-2-html5.mp4
I made the correction and safed again but its still now visible.
Via the browser this link works.

Perhaps changing the file name to be only lowercase will fix it?

Hi Vlad,
thats it! The lowercase fixed the issue! Thank you.

Unf. I still have to come back again with a questioan… I checked the design with my ipad and here the video doesnt load. I see the text layers but no video. MP4 should be fine with apple. Do you have an idea to fix it?
Thank you!

The video might be too big. Also, as far as I know ipad doesn’t support the autoplay feature.

well, this is how it goes with apple…
Is there a chance to have another landing page for apple devices?

No, not really. But you can disable the slider for mobiles if you want.

Or you can set a poster image and that should be displayed instead of the video.

A Poster image sounds great but unf. I dont have a clue how to do it. I found following example:

<video controls poster="/images/w3html5.gif">
<source src=“movie.mp4” type=“video/mp4”>
<source src=“movie.ogg” type=“video/ogg”>
Your browser does not support the video tag.
</video>

Could you say me where I can set that video control option?
Thanks a lot!

You need to go back to your slide where you set your HTML5 video (in Revolution), edit the video and you’ll see that the first option is for the poster image.

Thanks it works!

Back on this topic :slight_smile:
I have the following strange behaviour: On my devices the slider on the welcome page (home) works perfect on all devices (two different computers, ipad and mobile phone). On my friends computer it doesnt work at all (on no devices even with several browsers. He sees the youtube videos on the following page without any issues (also rev sliders): http://looptheglobe.de/thats-me/video-projects/

As a test I switched the video on the front slider also to a youtube one. But unf. he also doesnt see this one. Just an empty background in the choosen background color…

Do you have any idea what could be the reason?

Thanks again for your help!

I fixed it or lets say I know the reason. Its connected with the xili plugin I have installed. My friend has choosen another language and the slider is not included in the translated page yet. So this issue is closed. I will work on the translations later.
What multilanguage plugin can you recommand? Xili (for free) or WPML (not free)? Are both compatible with Moesia Pro?
Thank you.