Using aReview Comments with Jetpack Comments


#1

Hi Vlad,
I’ve just enabled JetPack comments on my site… but it doesn’t seem to work. Have read a few online forums and realized that it doesn’t work well if the theme has comments options as well.
One thread mentioned to remove the <form></form> tags from comments.php and replace with
<?php comment_form(); ?>

I couldn’t find these tags as i see that aReview is set-up differently.
Is there some code i can change to have Jetpacks comments work? since they already have the login option for facebook, twitter, etc.

Thanks in advance!


#2

Areview is set-up with the comment_form. You can find it in comments.php. Not sure why it wouldn’t work and I can’t really test at the moment.


#3

Hi Vlad - Just an FYI.
Tried a bunch of different options, but it still doesn’t work like jetpack has show on their site. The icon buttons to login from different social media sites doesn’t show up, and once a comment is posted it doesn’t show up.

Will the ‘Disqus Comment System’ plugin work with this theme?

Also another issue has just shown up… I didn’t notice this before. The breadcrumbs (i think that’s what it’s called) are not aligned on the category pages (Insights/Blog). The (date/author/category) - the author is a little below the other two besides it. here is the link …
http://www.creativeminer.com/category/insights/


#4

Hello,

Here’s the code to fix the second issue:


.blog.group-blog .byline {
   position: relative;
   top: -7px;
   margin-right: 10px;
}

I’m not sure why Jetpack wouldn’t work. If you look in comments.php you can see wp_list_comments and comment_form. Both are default WP functions, so we’re basically not doing anything custom regarding the comments, other than styling.

Disquss works, I just tested. Though it might need some styling cause it’s using mostly light colors. So if Disquss works, Jetpack should work too.


#5

Thanks Vlad.
I pasted the code in the custom CCS Editor and saved… but it hasn’t fixed the alignment issue. Isn’t this being generated from ‘div.post-info’ ?

For the comments issue… i’ll try Disqus. I’ve seen others face similar issues with jetpack on some of the forums. Will try some other options over the weekend.


#6

Sorry, use this:


.archive.group-blog .byline {
   position: relative;
   top: -7px;
   margin-right: 10px;
}

I’ll check the Jetpack at some point, but at the moment I can only run it in dev mode, and I don’t think the comments module works in that.


#7

Voila… the code fixed it. Super!
Sure thanks much for your help. Appreciate it!


#8

Hi Vlad.
Thanks for all your help you provided last year. I finally used Disqus Comments with aReview and it works fine.
Wishing you a great year ahead in 2015!
Thank you!