Urgent - product page

Ok, we have spent the whole day, from 7am to now 10PM) with millions of options to try and get more that 7 products (default) showing on a page with no luck.

I have also loaded a test directory uploading the theme here as well.

Images

Test site pg 1 Only allows 7 products and 2 blank spaces

Test page2 also only 7 products and 2 blank s paces

The million’th try to get code to work on our site, still only leaving us with 7products per page

Our site http://fuhndeals.co.za/shop/ - here you see the 8th product going onto page 2

Hello Judy,

You can change the number of products that are displayed on the Shop page by changing the value of Blog pages show at most property in your Dashboard → Settings → Reading.

Kind Regards, Roman.

Hello Roman done ALL that. Used all the variations of code and NOTHING changes it.

Used this code in various ways
<?php
add_filter( ‘loop_shop_per_page’, create_function( ‘$cols’, ‘return 9;’ ), 20 );

on its own
add_filter( ‘loop_shop_per_page’, create_function( ‘$cols’, ‘return 9;’ ), 20 );

/**

  • Woocommerce
    */
    add_filter( ‘loop_shop_per_page’, create_function( ‘$cols’, ‘return 9;’ ), 20 );

and many many other ways we got from googling…

Ok, I deactivated Jetpack and now all the products are on one page…but now another problem arose, SIDEBARS have moved to the bottom, why, and how do I fix this. :frowning: Seems as though page has widened.

Sidebars dropped to bottom

Thank you Guys, I solved the problem. Jetpack has a problem with “Infinite Scroll” . I deactivated that and product number shows as it should now. Regards to the sidebars moving to the bottom, I deselected ‘Full width blog posts’ from customize - blog posts.

You are welcome Judy,

And have a nice day :slight_smile:

Kind Regards, Roman.