Update to sydney 2.10 failed

Hi,

My account page shows expiry on February 10 but I cannot update to new version of Sydney Pro.

Error message is as follows:

Downloading update from https://athemes.com/edd-sl/package_download/MTU0NDY1ODU5MDphZDM3OTg2ZTA0MDk5ZGYyYzQzZGFkODZmNzU3ZmI4ODoxMDg0Mzc4OjZiM2FjZjcxNmIzYTYwYTkzMDQyMzgxNzgyZWJlMjM2Ojow…

An error occurred while updating Sydney Pro: Download failed. Unauthorized

Hello there,

I am sorry for the inconvenience.

Probably there’s a server to server communication issue at that time. Please try once again. Let me know if it still fails. DM-e your email account you used to purchase, so that we can check it from our system.

Regards,
Kharis

Once your license expires, as yours has, you are no longer eligible for automatic updates. You can renew your license from athemes.com/your-account

Hi Charlie,

I see February 2019 as the end of my license. Am I wrong?