Unable to Find Site Branding

Hello,

New developer here…I’ve had a chance to work with several of your themes and continually recommend aThemes to clients when I’m working with WordPress. Currently, I’m using Perth and can’t seem to figure out what I did to the site-branding/site-logo.

After adding the logo, I tried both “inline,” and “centered,” menus and cannot seem to find any HTML that would even hold the logo. After reading through the forum, I tried increasing max-height on .site-logoand increasing z-index on .site-branding.

I’m guessing this is something really simple that I’ve completely overlooked, but I can’t find anything in my CSS that would have hidden the site-branding section. Any help is greatly appreciated!

Blake

Site: http://tbafitness.treatsandpraise.com/

Dear Blake,

Thank you for reporting.

I assume that the Perth theme installed on your site has been modified (probably by someone else?). I found the following markup is missing.

<div class="site-branding col-md-4 col-sm-6 col-xs-12">
...
</div>

Backup your existing Perth theme to your local drive, in case you have made hard code modifications before. Then try to completely delete it, then reinstall it through Apperance > Themes > Add New > Type “Perth” in the search themes input field > Install > Activate.

I hope this reply helps.

Warmest regards,
Kharis

Thank you for the speedy reply. Hmm, I’ve never touched the parent HTML, I’m not sure how that could have happened, possibly a plugin I tried out and deleted? I will backup and reinstall.

I appreciate the help! I was really confused why I could not figure that out.

Thanks,

Blake

Dear Blake,

To reinforce your site’s security in the future, I’d suggest you to use the WP Security Audit Log plugin.

Warmest regards,
Kharis

Thanks for the suggestion, I definitely will be tracking changes going forward. For the amount of time I just spent on a problem like this, it will be well worth it.

Hello Kharis,

Unfortunately, the problem was not as simple as missing HTML. Before reinstalling the theme, I looked at the header.php file and found the missing code (below) was still in the file, yet still not showing up.

div class="site-branding col-md-4 col-sm-6 col-xs-12

I tried the following fixes:
Pasted in a fresh copy of header.php.
Disabled all of my plugins with the exception of PageBuilder.
Commented out my entire child theme.
Finally, I reinstalled Perth with plugins disabled.
Still no .site-branding.

At this point, I am guessing a workaround like copying header.php to my child theme and hard-coding the HTML makes the most sense, but I figured I would share this with you in case something like this pops up again.

Definitely open to suggestions.

Thanks!

Dear Blake,

Thank you for updating me.

> At this point, I am guessing a workaround like copying header.php to my child theme and hard-coding the HTML makes the most sense

I just realized that you’re currently using a child theme. If you have already had the header.php file in the child theme, the site-branding might be missing here. Yes, you should do inserting the div.site-branding markup into it.

Warmest regards,
Kharis