Turned-off comments on blog but comments area still display

Dear sir/madam

I have recently tried to remove the comments section from my blog pages.

I am using comments the evolved plugin and therefore do not need the default wordpress comments on my blogs. However, I find that when I use this plugin on blog pages an additional row appears above my copyright row that is where the comments would usually be displayed for comments on your Sydney theme blog page.

I am using this CSS code to remove the comments (below)

.single-post .entry-header {
display: none !important;
}
.page .page-wrap .content-wrapper, .single .page-wrap .content-wrapper {
    padding-top: 0 !important;
}
.entry-footer {
    display: none !important;
}
.post-navigation {
    display: none !important;
}
#comments {
    display: none !important;
}

(Above) is the CSS code I currently use…

Unfortunately however, when using this code a blank row displaying the background still appears. see here:
http://www.gogohopping.com/10-things-you-must-do-when-visiting-thailand/

Please can you provide the CSS code that will help to remove the comments area from my blog pages?

Any help you can provide will be appreciated.

Thanks

Paul.

Hello Paul,

Try to edit each post, expand Screen Options section at the very top, make sure that Discussion checkbox is checked, scroll down and uncheck Allow comments checkbox.

You can also configure comments functionality in Settings → Discussion section.

Kind Regards, Roman.

Hello Roman,

Thanks for your reply.

These are my settings (below) but the white space still appears.

Thanks

Paul

Hello Paul,

It looks like you wrapped HTML header of the code that you added in text widget into <p></p> tags, you can try to unwrap it and see if it helps.

Kind Regards, Roman.