Trying to get property of non-object in sydney-portfolio.php

Hi, my new site have error:

Notice: Trying to get property of non-object in /hermes/bosoraweb166/b1833/ipg.visionlenscorpcom/discon.com.ve/wp-content/plugins/sydney-portfolio/sydney-portfolio.php on line 62 Notice: Trying to get property of non-object in /hermes/bosoraweb166/b1833/ipg.visionlenscorpcom/discon.com.ve/wp-content/plugins/sydney-portfolio/sydney-portfolio.php on line 62 Notice: Trying to get property of non-object in /hermes/bosoraweb166/b1833/ipg.visionlenscorpcom/discon.com.ve/wp-content/plugins/sydney-portfolio/sydney-portfolio.php on line 62

how can i fixed?

thanks,

www.discon.com.ve

Hi,

Exactly where you have these errors? Also what happens if you disable all your plugins? Please let Us know.

Best Regards,
Csaba

Hi Csaba, between testimonial and portfolio row(Que dicen nuestros clientes- Los productos).
cheking disable all plugins

Thanks

Below BLOG button same error, all plugins disable, you can check now

http://www.discon.com.ve/

Thanks

Hi,

I think I have to check this issue further in your wp-admin, please send me an admin access to your site in e-mail to csaba.athemes@gmail.com and I will check this issue further in your wp-admin.

Best Regards,
Csaba

@frankelou
Hello there,

These are not errors, they are notices, which means that everything is fine but you are not doing something right. If you check our documentation https://athemes.com/documentation/sydney/ for portfolio plugin, you will see that you can use following shortcode:
[sydney-masonry posts="8" show_all_text="See all" post_type="projects" filter="yes" include=""]
and for one of its attributes you can specify category slugs like this:
include="landscapes,people,cars"
Problem is that you have specified one or more slugs which do not exist, so you can remove theme from the shortcode or you can create them. Fixing this in any way will remove notices from front end.

Note that notices are showing because you have set WP_debug to true inside wp-config.php file, and this constant should be set to falase - check Codex in order to change this https://codex.wordpress.org/WP_DEBUG

WP_DEBUG should be disabled on live sites, and it should be used for debugging purposes when something is not working.

All the Best!