Trying to add Sidebar to Posts

Hi,

I’m trying to add a sidebar to my posts so my posts all look like this page: https://eblawtexas.com/news-and-information/

However, I don’t have template under the post attributes that has a sidebar and when I tried to add the Custom Sidebar Plugin that doesn’t seem to do it either.

I don’t need anything fancy, just want to display the same sidebar from the URL above on all my posts.

Thanks for the help!
Matt

Hi Matt,

Thank you for contacting us. I am happy to help with your queries.

If you have a blog page, that is enabled on posts page setting under the Dashboard > Settings > Reading > Your homepage displays, the widgets sidebar enabled on Appearance > Widgets will automatically appear.

If it is not appearing, the problem maybe with your current blog page. Can you share a link to it, so I can inspect and help you in a better way?

Regards,
Kharis
aThemes Support

The blog page is selected in the Reading section so the sidebar shows up on that page, but I can’t get it to show up on the actual blogs. The Site is https://www.eblawtexas.com/news-and-information (that’s the actual blog page). Thanks for the help Kharis.

Hi,

Try enabling default page layout on your specific each post’s Elementor editor.

Regards,
Kharis
aThemes Support

Hey Kharis,

That’s the one I’ve got selected and it’s still not showing any sidebar. I took this screenshot from the most recent blog post. URL: https://eblawtexas.com/contractual-terms/

Thanks for the help.

Hi,

Thank you for getting back along with the screenshot.

Can you share your widgets settings under the Appearance > Widgets? Perhaps special setting that presents in there causes you this issue.

Regards,
Kharis
aThemes Support

Here’s a screenshot of the widget section. I even tried installing a sidebar plugin to see if that would fix the issue (it didn’t).

Hi,

Thank you for sharing the screenshot.

Seems likely you have an additional sidebar plugin. Perhaps there is a special setting that hides the sidebar area from single post page. To verify this, you may want to try disabling it temporarily.

Can you share a link to the plugin, so I can try?

Regards,
Kharis
aThemes Support

Here’s the plugin I installed to try and add the sidebar after I couldn’t find it or figure out how to get it added to Posts. It didn’t fix the problem either though. https://wordpress.org/plugins/custom-sidebars/

I have deactivated it for the time being since it didn’t help anyways.

Hi,

Thank you for sharing the plugin link.

Can you try disabling the option that says “Allow this sidebar to be replaced” on the current theme’s sidebar, that is located under the Appearance menu > Widgets?

If disabling this doesn’t change anything, to check whether it’s a post specific issue, try creating a test post with default template enabled. And check whether the sidebar shows up or not.

Screen Shot 2021-03-02 at 10.46.51

Regards,
Kharis
aThemes Support

Hey Kharis,

I don’t see the option: “Allow this sidebar to be replaced” anywhere under Appearance menu > Widgets. Is that something that is only visible with that alternate sidebar plugin installed? Currently I have that plugin disabled.

I have tried creating a new post and its not a post specific issue as the sidebar doesn’t show up by default or if I select the Default template under Post Attributes.