Top and bottom padding don't work

Hello

I wanted to remove the page title from all pages, so I used the css code below and that worked, but the problem is that it creates a gap between the header and the the actual page content, so I tried to reduce the padding but no matter what number I put it doesn’t make any changes neither with the footer nor with the header. Dashboard → Appearance → Customize → General→ reduce top padding

I used this CSS to hide the page title
.page.hentry .title-post {
display: none;
}

Hi,

Can you share a link to the page you need help with, so I can inspect it directly and some corrections to your CSS code?

Regards,
Kharis
aThemes Support

It’s this site here: https://ighilkarim.ca
it’s not finished yet
thx

Hi,

As checked, I didn’t get .page.hentry .title-post presents in your homepage. Can you share links to specific pages?

Regards,
Kharis
aThemes Support

There is a gap in every page…this page for example: https://ighilkarim.ca/acheteurs/

Thx

Hi,

As checked, the extra spaces are from the most top Elemento sections. You should be able to manage them from padding option on each section’s settings.

Regards,
Kharis
aThemes Support

Hello

It’s not the elementor padding, I double check all that and I even added a background image en purpose but still there is a gap between the content and the header, see this page here: https://ighilkarim.ca/acheteurs/

Thank you for your help

Allo…any idea why this happenning?

Hi,

​Please accept my apologies for the delay in response. I really appreciate your patience.

Try accessing the Page Settings when you edit page with Elementor. Then enable Front Page on Page Layout option. Save page.

I hope this helps.

Regards,
Kharis
aThemes Support

Hi

I try all that before, and no mater what page layout I choose the gap remains there… I also wanted to have a featured header image for pages, so I added this code below and yet no image header is shown as if I did add anything.

    .page-id-1058 .header-image{
      background-image: url('https://ighilkarim.ca/wp-content/uploads/2020/12/Big-house.png');
    }

See these videos here:

Thx

Hi,

From Page Settings, upload a featured image, and enable ‘Featured header image - Wide’ template.

Update. And this would fix your problem.

Regards,
Kharis
aThemes Support