Theme issues (mobile) after update

I did do the cache clearing and checked the site from the desktop. The computer version looks fine, it’s just the mobile version that seems to have lost the settings. I tried both on safari and chrome on my iphone.

The demo area in the customizing area of Sydney shows the site as it should look (and did until just recently.)

What should my next action be here?

I have screen shots available if that’s helpful.

Hello there,

Some screenshots would help me better to figure it out. Since we can’t process direct image attachment here, you have to upload your files to the free file hosting service like Google Drive and share their public links here.

Please share your site URL here, so I can have a look directly.

Regards,
Kharis

Hello Kharis and Kesnow,

I am also having the same problem on my site http://sindalesc.org.br/ I am using the GREATMAG FREE version.

The site offers two viewing options in the mobile version. At first access to the “mobile site” version. It is only after you change to “view the complete site” in the page footer that this problem corrects.

Do you have any tips so I can make the correction?

Thanks, Diego Borges

Hey,

Print from the screens

Error version
https://drive.google.com/open?id=0B40qYuQXHHrodWhzNloxcXBWZmc

Correct version
https://drive.google.com/open?id=0B40qYuQXHHroVHBGSVVWSTF3U1U

Thanks, Diego

Kharis,

Another problem in the mobile version is for MENUS.

The MENUS 2nd and 3rd level links are not opening in the mobile version.

Desktop version - CORRECT
https://drive.google.com/open?id=0B40qYuQXHHroLWs4NTlkemxLd1k

Mobile version - ERROR
https://drive.google.com/open?id=0B40qYuQXHHroYVozSnZaYVJzdGM

Thank you, Diego

Hello there,

Based on the screenshot you shared, the default responsiveness design of Sydney is altered with the mobile theme module by Jetpack. You can disable it from Jetpack settings panel > Writing tab > Theme Enhancements section.

Regards,
Kharis

Hi Kharis,

I was able to solve this problem. Thank you very much.

Now I need to know why the error in the menu.

Hug, Diego

Hello Diego,

I am sorry, the mobile menu problem on Greatmag is considered as bug that should be resolved in the next version update. At the meantime you could resolve it yourself by doing these steps:

  1. Edit the greatmag/inc/nav_walker.php file
  2. Replace this line:

if ( $args->has_children && $depth === 0 ) {

to


if ( $args->has_children ) {

  1. Install and activate the TC Custom JavaScript plugin
  2. Go To Appearance > Custom JavaScript
  3. Paste the following code into the provided box

;(function($) {

  "use strict";

  // Enable mobile menu dropdown
  $('.auth-social-nav .dropdown-menu [data-toggle=dropdown]').on('click', function(event) {
      event.preventDefault();
      event.stopPropagation();
      $(this).parent().siblings().removeClass('open');
      $(this).parent().toggleClass('open')
  });

  $('.off-canvas .dropdown > a.dropdown-toggle').on('click', function(event) {
      if ( $(window).width() <= 767 ){
        event.preventDefault();
        event.stopPropagation();
      }
      $(this).parent().siblings().removeClass('open');
      $(this).parent().toggleClass('open')
  });

})(jQuery)

  1. Update

Regards,
Kharis

sorry wrong entry, I was trying to ask question on another thread. My apologies.