The preview could not be loaded issue on blog page

Hello all,

I was having some issues while I’m trying to edit the blog page in Sydney theme using Elementor. I tried those debug tips (safe mode, remove extra plugin, permalinks, etc.), and the suggestions on other post, cannot get it to work. To eliminate any potential problems on my WordPress, I remove the whole site and create a brand new one, this issue cannot be solved still. It didn’t happen to the home page, only the blog page. I was struggling on this for a week, create and rebuild the site for multiple times. Is there anybody knows how it get it solved? Your help will be very appreciated!

Hi,

Thank you for contacting us. I am happy to help with your queries.

Can you share a link to your blog page here, so I can inspect it directly?

Did you enable your blog page as posts page from Settings > Reading panel? If so, I am afraid, the page is not editable as WordPress system uses its URL as the index page for posts. The page content itself is replaced with list of posts. This is not an issue to resolve. Because the current mechanism works the way it is.

Regards,
Kharis
aThemes Support