Text formatting in Moesia FP: Blockquote?


#1

When I paste text into “Enter your blockquote…” field with simple formatting (e.g. line break),
the formatting doesn’t appear on the page. I have a “minifide” text without any line separation.

Is there any way to enable support of text formatting for this widget, just to make text more readable?


#2

Hello there,

For security purpose, HTML tags are stripped out. Alternatively you can insert a [break] tag within your text.

43

Save page

Then do the below steps:

  1. Install and activate the TC Custom JavaScript plugin
  2. Go To Appearance > Custom JavaScript
  3. Paste the following code into the provided box
    ;(function($) {

     if( $('.widget_moesia_blockquote blockquote').length ) {

       $('.widget_moesia_blockquote blockquote').html(function(index,html){
         return html.replace('[break]', '<br/>');
       });

     }

    })(jQuery);
  1. Update

Flush site caching (if enabled) before reloading your page. Otherwise the new code addition won’t take immediate effect in the front end.

https://codex.wordpress.org/I_Make_Changes_and_Nothing_Happens

Regards,
Kharis


#3

Thank you!
It works, but only 1 time.
If I insert [break] only once - it works.
But if I insert it several times in the text, it works only first time, rest will be shown in text:
e.g.:
… but a bit ‘lost in translation’ – breakfast, lunch and dinner?[break] Help is now one touch away[break] With ONE-