Sydney toolbox activation error

Hello, I am running the Sydney theme version 1.45 on WordPress 4.9.4 which uses SiteOrigin Page Builder and Sydney Toolbox.

The theme desires:
The following recommended plugin is currently inactive: Sydney Toolbox - custom posts and fields for the Sydney theme.

And generates the following error –

Plugin could not be activated because it triggered a fatal error.
Parse error: syntax error, unexpected ‘[’ in C: \Data\WebHosting\HostingRoot\ksc\www.kelses.com\wwwroot\wordpress\wp-content\plugins\sydney-toolbox\sydney-toolbox.php on line 103

I have actually already tried deleting the plugin, and re-installing, then even deleting via FTP the plugin FOLDER and re-installing from scratch, to the same result.

But it looks like there might be an issue with the plugin code itself?

Kurt Griffith
Fantastic Realities Studio

Investigation shows my client’s hosting is using PHP 5.3.28, and the plugin seems to require PHP 5.4. They are using shared hosting, so I do not have c|panel or similar access, and have to wait for the ISP’s help desk to tend to it.

But I think I properly should have gotten the error:
Sydney Toolbox requires PHP 5.4. Please contact your host to upgrade your PHP. The plugin was not activated.

Hello Kurt,

I would suggest you to refer to WordPress requirements:

Please note that PHP 7 is about twice faster than PHP 5.

Kind Regards, Roman.