Sydney Toolbox 1.03 gives unexpected '['

I’ve updated Sydney Toolbox to version 1.03 but now it can’t be activated with this warning:

Parse error: syntax error, unexpected ‘[’ in /home/user/domains/domain.com/public_html/wp-content/plugins/sydney-toolbox/sydney-toolbox.php on line 100

I’ve deactivated all the other plugins but it gives still problems.

I have WordPress 4.9.6. and not so many fancy things. Is there anything wrong with this version or what can I try to fix this?

This could be because you are running an outdated version of PHP. If your host supports PHP 7.0 we would recommend upgrading to it.