Sydney theme not mobile friendly

Good day

I’m working on my website but now stuck with mobile optimization.

Website URL: https://electricians-sa.co.za/

When I test crawl the site with Google bot in google console, I get “page is not mobile friendly” on all my pages I tested.

I removed all my additional CSS code, widgets and disabled all plugins except those that came with the theme (Elementor/sydney toolbox) and still I receive the same mobile error in google console and Google mobile friendly test.

“Elements to close together”
“Content wider than screen”
All my image sizes are under 80KB.
It might be something simple I’m missing.

Any help would be appreciated.
Thanks

Hello there,

Not really sure if Sydney theme’s code specific issue. Because our demo loads fine on mobile device. Probably there’s improper configuration with page builder content.

I tried to access your site, however the screen only displaying this

02

Please fix it first. Is there any IP country restriction? If so, please temporarily disable it.

Regards,
Kharis

Thanks for the response.

I’ll have to check with my new host for any geo restrictions set, as I don’t have any set on my end. Disabled all security etc. Website opens fine from hunnington beach LA, Australia and locally in South Africa.

I have removed the header image under customization and set it to no header, now it gets crawled being mobile friendly.

Are you okay without header image? Do you still need an assistance with it?

Regards,
Kharis

Without using a header image worked for a few hours, without making any further changes, my website is mobile friendly in the Google mobile friendly test tool but when I inspect any URL on my website in Google Console, I get “Page is not mobile friendly” again.

Google rendered differently and looks incomplete compared to actual mobile device.

mobile-friendly-screenshot

It looks like this on my iPhone.

I don’t know what might be happening with Google’s engine. Probably your site loads too slow on their server. Try to optimising your site’s performance. Follow this code for complete guide. https://codex.wordpress.org/WordPress_Optimization/WordPress_Performance

Regards,
Kharis

At least, Google crawled my pages as mobile friendly now in Google search console except the contact us page.

I’ve activated the fast caching plugin, enabled gzip and will work to enhance the website performance as much as I can today.

Thank you for your excellent assistance.