SYDNEY PRO: Sharing home page

Hello,

I am having trouble updating the image that is shared for the homepage www.thegarretpodcast.com. Social media always picks up the header image, even though I have uploaded an separate image to the page.

I do NOT have this problem on any other page, it is specific to the homepage.

Thank you for your help.

Hello there,

Thank you for getting in touch. I’d like to help, but I couldn’t exactly get the issue you’re explaining. If I am not wrong, you could use different image preview for homepage showed on social media. Is that correct? If so, you’d need to do some extra steps to set custom image for social sharing, the most favorite way for me is use YOAST SEO plugin. You could follow the steps as clearly explained here in this page.

Regards,
Kharis

Hello Kharis.

I already use the Yoast plugin. It works on everypage EXCEPT the homepage.

I am trying to figure out what settings I need to change on sYdney Pro for Yoast to work.

Hello there,

Viewing the source code of your homepage, I didn’t find any tag that represents social sharing image. Normally, this tag will present:

`<meta property="og:image" content="http://yoursite.com/path/to/image.jpg" />`

Edit your homepage, in Yoast SEO options, click on Social tab, then upload your image.

Regards,
Kharis

Hello Kharis. I already use the Yoast plugin. It works on everypage EXCEPT the homepage. I am trying to figure out what settings I need to change on the Sydney Pro homepage for Yoast to work. Can you please help?

Hello there,

For efficiency reason, I need to check it directly from your admin area and test it myself. Please share the working login credentials to your site admin area (/wp-admin). Ensure admin rights enabled.

Mention the link to this topic in your email body to indicate it’s a followup of this conversation in the support forum.

Regards,
Kharis

Hello Kharis,

I have sent the information to you via email.

Cheers.

Hello Kharis,

removed

Thank you.

Cheers.

I am inspecting it. And will write you back ASAP.

Regards,
Kharis

Hello Kharis,

Have you had any luck inspecting the issue?

Hello there,

I’ve added the open graph image meta tag to your homepage manually with the below PHP code via Code Snippets plugin.

    function sydney_pro_child_add_image_meta() {
      if( !is_front_page() ) {
        return;
      }
      ?>
      <meta property="og:image" content="https://thegarretpodcast.com/wp-content/uploads/2018/05/6B780995-C7BC-46BD-8C54-EBAC94163E32-e1526948336547.jpeg" />
      <?php
    }
    add_action('wp_head', 'sydney_pro_child_add_image_meta');

It should be working now. Here’s my test:

Regards,
Kharis

Hello Kharis, this now works beautifully. Thank you.

You’re welcome!

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis