Sydney not loading properly in mobile and tablet

I know this topic has been covered previously, but none of those solutions seem to apply to my site (www.windhorsestrategic.com) in either phone mobile or tablet versions. In particular, I have photos associated with text sections (What we do, About us) created in Elementor (two columns). I also have a little bio section with a photo and button (More about me). The front page appears fine not the desktop view, but in mobile or tablet the photos are cut off and barely displayed. The bio section places the my photo and button over the top of the previous section.

I’ve run the Google Mobile Friendly test and while it says my site is mobile friendly, there are 20 page loading issues, none of which I understand as it’s beyond my WP skill level to understand. I have attached a few photos to show the issues.

Would greatly appreciate input on how to resolve this issue for my site.

Hello there,

Ideally you should use an image object instead of column background image. If you still want to use a background image as it is now, try adding this CSS code to Appearance > Customize > Additional CSS from dashboard.

    @media only screen and (max-width: 1024px) {
      .elementor-element-6561acf > .elementor-column-wrap,
      .elementor-element-dad0506 > .elementor-column-wrap {
        min-height: 100vh;
      }  
    }

Regards,
Kharis

Thanks Kharis. I opted for the image object over more code. Seems to have worked. Much appreciate your support!

You’re welcome!

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis