Sydney, Mega Menu 2.5 submenu not visible

Please Help,
I am using Sydney version 1.49 and Max Mega Menu version 2.5
The Max Mega Menu submenu’s are not visible on my site, it looks like the submenu’s are behind all other content on the site. ( In my case Smart Slider 3 )
When I downgrade Sydney version 1.49 to version 1.39 everything works fine
Are people experiencing the same phenomena and found a solution ?
Regards Ge Timmer

Hello there,

It’s probably due to main menu CSS update in the Sydney version 1.49. To help me inspect what’s exactly causing you this, please share a link to your site. If you want it to remain private, you can email it at kharisblank@gmail.com. Mention the link to topic to indicate it’s a followup from support forum reply, so you’ll get highest priority.

Regards,
Kharis

Hello Kharis
Thank you for your help.
The link to the site is http://www.stedelijkmuseumvianen.nl
At the moment as a workaround, the site is using the Sydney theme version 1.39
The phenomena shows on version 1.49 when you hover over the top bar Museum, there the menu goes behind the slider.
If you want me to update to Sydney version 1.49 no problem.
Thanks in advance
Regards Gé Timmer

Hello there,

I checked it. Now please enable Sydney version 1.49. So I can compare and troubleshoot it from my web browser’s inspector.

Regards,
Kharis

Goodmorning Kharis,
Thank you for your effort,
I enabled Sydney version 1.49. on the site http://www.stedelijkmuseumvianen.nl
On version Sydney 1.49 the phenomena shows. You can see on hover Museum, the MaxMegamenu window is working , but the MaxMegamenuwindow is behind the slider.
I did some testing on a page with a different layout, containing the menu and just text, ( without the slider ) there the menu window appears also bind the tekst.

Thanks in Advance
Regards Gé Timmer

Ha Kharis,

Done, I have enabled Sydney version 1.49 on the site

Regards Gé Timmer

Hallo Karish,

  The phenomena is introduced in Sydney version 1.47, with version 1.46 the site was working as before.

  After your suggestion, that, this might be caused by a css change I found a difference in the file style.css on line 3280

  There is the on line 3280 in file style.css version 1.47 the following code

.panel-row-style, .elementor-section {

          -webkit-transform: translate3d(0,0,0);

}

When I remove this section, it is working as expected.

You are right, the phenomena is caused by css code.

Please advise, how can I continue from here ?

Regards Gé Timmer

Please try adding this CSS code to Appearance > Customize > Additional CSS from dashboard to disable it without editing the main stylesheet.

.panel-row-style, 
.elementor-section {
   -webkit-transform: unset !important;
   -moz-transform: unset !important;
   -o-transform: unset !important;
   transform: unset !important;
}

Then add this one to enable it only in content area.

.content-wrapper .panel-row-style, 
.content-wrapper .elementor-section {
   -webkit-transform: translate3d(0,0,0);
   -moz-transform: translate3d(0,0,0);
   -o-transform: translate3d(0,0,0);
   transform: translate3d(0,0,0);
}

Let me know how it goes.

Regards,
Kharis

Hallo Kharis,
You have been a great help, thank you.
I implemented as you suggested, problem solved.
regards Gé Timmer

Time to the impementation took very long, excuses for that.
The reason for that was not related to your support nor the web site

You’re welcome!

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis