Sydney Child Theme Not Taking Effect

Hi there,
I’ve read many different versions of enqueue code snippets and tried all sorts of slightly different syntax but I can’t get the CSS in the child style.css to take effect. The same code worked perfectly in the Custom CSS box on the parent theme.

Here is my functions.php:
<?php
function my_theme_enqueue_styles() {

$parent_style = 'parent-style'; // This is 'twentyfifteen-style' for the Twenty Fifteen theme.

wp_enqueue_style( $parent_style, get_template_directory_uri() . '/style.css' );
wp_enqueue_style( 'child-style',
    get_stylesheet_directory_uri() . '/style.css',
    array( $parent_style ),
    wp_get_theme()-&gt;get('Version')
);

}
add_action( ‘wp_enqueue_scripts’, ‘my_theme_enqueue_styles’ );
?>

And here is my style.css

/*
Theme Name: Sydney Child
Theme URI: http://athemes.com/theme/sydney
Author: aThemes
Author URI: http://athemes.com
Template: sydney
Version: 1.0
License: GNU General Public License v2 or later
License URI: http://www.gnu.org/licenses/gpl-2.0.html
Text Domain: sydney
*/

h2 {
color: #ff0000 !important;
}

h3 .widget-title {
color: #ff0000 !important;
}

.site-info { display: none; }

#colophon {
margin-bottom: 5px !important;
padding: 0px !important;
}

I would very much appreciate help in what I’m doing wrong.
Thank you!

I just went and activated the parent theme and it all took effect! I’d never read that I needed to go back and do that! I think there should be more explicit instructions for the child theme. Is that all I needed to do? Reactivate the parent?

False alarm. I still have the problem.

Argh.

Hello there,

Please download and study our premade Sydney child theme.

Regards,
Kharis

I did that already, that’s where I got the theme from but it didn’t work. So then when I looked up the codex on the wordpress site and in this forum I saw that there were suggestions to also call the Child theme from the fuctions.php file so I added that.

Hi,

In your child CSS, the URI must be the child theme directory address like
http://your.site/themes/child-theme-directory/

I’m not sure that’s your problem but try to start with that.

Basically, you don’t need to manually enqueue the child theme’s main stylesheet as the system already does it when the child theme is active. I tried to paste your custom CSS code into my child theme’s style.css and it works fine. Maybe your site is being cached by a plugin like W3 Total Cache? If so, you need to flush the cache after adding new lines of code.

Regards,
Kharis