Stop using headings in menu and widget titles

My site: https://featherrivercountry.com/

What files and CSS must I edit to stop using heading tags (h3, etc.) in my main nav and widget titles. I don’t like the text styling in those areas and I don’t think it’s good SEO.

If I can’t stop the theme from using headings in those areas, at least allow me to change the font family for the smaller headings (h3, h4, h5, h6).

Thank you for any help. I love this theme.

Jim

Hello Jim,

  1. I have just checked your header code, but I don’t see any headings in your menu, only links and list items. Can you please specify your menu issue more precisely?

  2. You can change your widget titles in Dashboard → Settings → Page Builder → Widgets tab → Widget Title HTML. However, I really think that headings are okay, you might want to check this post:
    https://yoast.com/headings-use/

Please feel free to ask any other questions that you might have.

Kind Regards, Roman.

Hi Roman,

  1. I discovered that the headings font I specified was also applied to #mainnav ul li a, .portfolio-info, .roll-testimonials .name, .roll-team .team-content .name, .roll-team .team-item .team-pop .name, .roll-tabs .menu-tab li a, .roll-testimonials .name, .roll-project .project-filter li a, .roll-button, .roll-counter .name-count, .roll-counter .numb-count button and all other buttons. I chose a display font for my headings and it didn’t look good used in so many places. I was able to change the main menu and other classes using my child theme’s style.css.

  2. The change of Widget Title HTML from H3 to H4 is not honored by the theme. I understand where the use of headings tags in the widget titles could be okay, but not H3. That heading is one I use often in content creation, which has more importance than the widget titles. I would like to find a way to make the theme use H4 for the widget titles, not H3.

I read the article you linked to and watched the video by Matt Cutts. I agree with them, which validates my opinion that the widget titles should NOT be H3. This is a minor nit compared to the overall quality of the theme (I really enjoy the flexibility of it), but still a nit I would like to solve.

Thank you,

Jim

Hello Jim,

Please describe what exactly you want to achieve.

Kind Regards, Roman.

Sorry for any confusion, Roman. As I stated in #2 above, “I would like to find a way to make the theme use H4 for the widget titles, not H3.” I am using a child theme.

Thanks,

Jim

Hello Jim,

I have just tried to change widget titles on my local Sydney install from h3 to h4 and it worked. I used this string:
<h4 class="widget-title">{{title}}</h4>

…instead of this:
<h3 class="widget-title">{{title}}</h3>

Kind Regards, Roman.

Roman,

That isn’t exactly how they appear in my Sydney theme. Where did you find that string? I searched all Sydney theme files for {{title}} and found nothing. I searched for <h3 class=“widget-title”> and found that string listed twice in functions.php. I tried doing a direct copy of the function in the parent theme to the function.php file in my child theme, but that just cause a server error on both the live site and the wp-admin. I had to replace the child theme’s function.php to recover.

So, can you tell me exactly how to accomplish this? I don’t know anything about PHP, so I need a little step-by-step (like, find this/replace with this) instruction.

Thanks,

Jim

Hello Jim,

As I mentioned in my first post of this topic, you can change your widget titles in Dashboard → Settings → Page Builder → Widgets tab → Widget Title HTML.

Kind Regards, Roman.

Roman,

I had forgotten that you mentioned that same sting in your first post. Sorry. But I did reply that the theme did not honor that setting. Changing that in Page Builder does not work for me.

Is there an alternative? Perhaps, as I mentioned above, there is a way to use functions.php to do this. I tried to do a copy & paste to add the function to my child theme’s functions.php, but my attempt only caused a server error message and a white screen.

Any ideas?

Thanks,

Jim

Hello Jim,

What indications made you think that the theme did not honor that setting?

Did you inspect title with browser tools and verify that there still is <h3> tag?

Kind Regards, Roman.

Yes Roman, that’s what I did. I made the change you suggested - both on May 31 and again today - and then inspected the element. I inspected with several browsers, in case there was a cache problem. In all cases, the title of the widgets remain as H3s.

You can check it out yourself: https://featherrivercountry.com/

Thanks for your patience on this lingering issue.

Jim

Hello Jim,

I have just checked that link and saw that your home page shows blog posts.

Can you please provide a link to the page that contains widgets in page builder grid? Also please make sure that you changed the setting mentioned above and cleared cache if you use any caching plugin.

In addition you can try to temporarily deactivate all your plugins except Sydney Toolbox and Page Builder by SiteOrigin, and see if it helps.

Kind Regards, Roman.

I realized that you probably want to change widget titles in your sidebar and not in page builder grid :slight_smile:

If yes, then I kindly suggest you to use WordPress.org forums to find a solution because that issue looks like general WordPress issue.

Kind Regards, Roman.