Spacing for portfolio


#1

Hi,

This forum has been really useful for starting my site.
My website link is https://cleanmyplanet.xyz.

However, as you might be able to tell, there are always huge, inconsistent gaps between the images of the portfolio on the front page. Is there a way to make the spacing smaller/more standardized like on the demo site?

Thanks in advance!

Chris


#2

Hello Chris,

Try adding this CSS code to Appearance > Customize > Additional CSS from dashboard.

.site-content {
  margin-top: 20px;
}

.home .site-content {
  margin-top: 0;

Regards,
Kharis


#3

Hi Kharis,

I used your code and it helped change the area between the hero header and first two posts on the homepage.

But is there any way to minimize the space between the first 2 posts and bottom 2 posts? I attached an image to show you what it is.

Thank you so much!

Chris


#4

Hello Chris,

The default spacing shouldn’t as huge as like that. See our demo: https://demo.athemes.com/ignis/.

Probably there’s a couple lines of scripts from one of your active plugins that conflicting with the default portfolio layout. To confirm it yourself, try disabling all active plugins (except the required ones), flush cache and re-run your test.

Regards,
Kharis


#5

Hey Kharis,

I deactivated all of my plugins and deleted the cache, but the problem persists! What should I do?

Thanks,
Chris


#6

Hello Chris,

Please check if you have lazy load script enabled.

Regards,
Kharis


#7

I don’t think it’s that. I tweaked a bunch of stuff, but it still doesn’t work. Could it be something with the image sizes?

Thanks,
Chris


#8

Oh wait. I realized I had lazy load enabled from Jetpack. I disabled it and I think it fixed it. Thanks for your help!

Chris


#9

Great! You got it resolved.

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis


#10