Space issues between header and widgets - Astrid theme

I’m having gap issues between the header, site-origin features, and site-origin headline. There is so much space that I couldn’t fix with css nor with padding setting within widgets. It seems to me the gap is caused by the theme not the widgets because not matter what I do with the size of the widgets, the gap is still there.

There is also the original background of the theme that I can’t get rid off. they can be seen behind the widgets.

For example, see the gap between the header and “WHAT WE DO” feature. Also, the gap at the bottom between contact us and the feature above it.

When I created the layout, I chose to replace current so I wanted to make sure that widgets I’m creating are overwriting the theme settings (kind of) so they can be balanced with other widgets. Right now, there are some widgets linked to each other which is good but other widgets have gap between which is why I am posting this thread :slight_smile: I hope I can find the answers.

The site is: https://cyberaty.com/

Thank you,

Hello,

Astrid theme is designed to work without Page Builder at all.

I would kindly suggest you to rebuild your home page accordingly to Astrid documentation:
http://docs.athemes.com/category/137-astrid

Please feel free to ask any other questions that you might have.

Kind Regards, Roman.

Hello Roman,

Thank you very much for taking the time to reply to my post.

Ok. I see. I wasn’t aware that I can’t use the Page Builder with Astrid theme.

I actually did use the Astrid documentation to build the site. However, when I look at the demo, it looks much better than when I imported the site. Also, i don’t see the edges in the demo but when I imported the theme, in the middle, there is like an edge around the widgets as you can see in “SERVICES”

My questions now are:

  1. Can I use SiteOrigin features and set it to Full Width with Astrid theme without having spaces between them ?
  • The space only happens when I set the Widget Row Layout to “Full Width”.
  1. can I import the demo as is with its designs in it so I can edit them according to my site ? The demo looks so perfect but when I imported it, it doesn’t come with all features.

I would really appreciate any recommendation.

Thanks again.

The border that you mentioned above is normal for regular posts and pages that shouldn’t contain any widgets.

  1. Try to select Widgetized page template for your home page instead of Full width template in order to get rid of space and border.

  2. Demo content should be imported properly if you follow documentation step by step. Please provide a link to the page with problematic demo content if you want me to help you with this issue.

Kind Regards, Roman.

Alright. I think the issue is almost resolved and I must have done this the wrong way originally :slight_smile:

so I was using the page builder to add features, headlines for my pages instead of using going Customize > Widgets > Add features. Also, set every page to Full. I can’t believe I wasted so much time trying to fix this :confused:

Right now, I selected Widgetized then all my home page content disappeared because I used the page builder. This makes sense according to your point earlier that Astrid theme doesn’t work without page builder.

I’m working on it now rebuilding the pages widgets. I will see how it looks like after and hopefully this will be the solution to my issue.

Thanks again Roman. You have been helpful as always.

Best regards,

I see now. The website has become more complicated and I have become so frustrated that page-builder doesn’t work with Astrid.

Managing the colors and background of the widgets & text is so inconvenient without doing it from Page builder.

If I have to do it by going to Appearance > Widgets > then editing from there, this will take forever to re do the whole thing.

I want to be able to edit it from the pages but after changing the to "Widgetized, all my existing widgets disappeared which makes sense because Astrid doesn’t support Page Builder.

I really liked Astrid theme but unfortunately it doesn’t seem to work well with how I want it to be.

Hello,

Did you try to add widgets in Customize > Widgets > Page - Homepage section? You should be able to handle styling there very easily, just expand widget, then expand Styling block.

Kind Regards, Roman.

Hi Roman,

Thanks a lot for your help. I was able to figure out the colors and the styling part. A good sign.

Right now, I’m working on adding widgets, features, headlines…etc. but the original font and widget size require modification to fit the website design. I tried using the styling block but it doesn’t do exactly what I’m looking for.

Also, I tried to use custom css but it doesn’t seem the widgets get updated with when I enter my code.

check out the website now: https://cyberaty.com

See the third Widget, I’m having hard time moving the icon a little bit to the left and the title to the top a litte bit. right now, it looks ugly. the font is so small.

Just give me a hint where I should be working on to fix these. I understand that this is not an issue with the theme. I just need to figure out where I’m supposed to customize the theme.

Hello,

Please create a new topic for this issue with some explanatory screenshots to keep forum in good order and make it easier to help you.

Kind Regards, Roman.