Space from top of the page

I have looked around the forum but can’t find a solution to the space at the top on my pages. I tried a few codes and switched to Front Page, but that didn’t really do the trick.

http://mkmayerlaw.com/?page_id=723

http://mkmayerlaw.com/?page_id=1388

thanks for any help

Hi,

I’ve checked your pages. Did you mean that you want to remove the white space below the main menu? if yes, you can use this CSS code below:

.sydney-hero-area {
    display: none;
}
.page-id-723 .page-wrap {
    padding-top: 0;
}

Put the code into Customizer > additional CSS

Regards,
Awan

Awan,
That did the trick, but it took off the sliding header on the homepage. Is there a way to get that back up? http://mkmayerlaw.com

Hi,

I thought you are not using the header slider for all pages. So, I give you this code to hide the header slider:

.sydney-hero-area {
    display: none;
}

There is a better way to manage the header slider from the customizer. Please open the customize > header area > header type > then choose “No header (only menu)” option for Site header type

Then, you can remove this css code:

.sydney-hero-area {
    display: none;
}

Awan,
Sorry if I wasn’t clear. I’m a noob at all this. Ok…so on the homepage I got the slider back up and I want the slider (I removed that portion of the code). But on the “About” and “Contact” pages there is so much space between the menu and the first image I have on the page. You have to scroll down a ways to get to the content of the page. That is what I am looking to fix. I changed the setting to in customize > header area > header type > then choose “No header (only menu)” option for **Site header type under the ****"Select the header type for all pages except the front page” but that space is still there. **

**I am attaching screen shots of the space. **

Thanks

So, just to be clear, I don’t have sliders on those pages…I just have a row with an image widget on the Contact page and then and a row and text and image widget on the About page.

Awan,
I figured it out….thanks for your help too. I used this code:

.page-wrap { margin-top: -100px !important
; } .header-slider { margin-bottom: -100px !important; }

and that got it where I wanted it. Thanks again for your help. Mike

Spoke too soon….It fixed the issue…but now the homepage is jacked up.

Glad to know you can find the code to resolve the issue.

You need to un-list the home page from your code. Please replace your code:

.page-wrap {
    margin-top: -100px !important;
}

to

body.home .page-wrap {
    margin-top: -100px !important;
}

Ya…I got it all taken care of. Thanks!!

1 Like