Social Menu Icon Help

Hi,

I’m using Sydney Pro on www.bh23consulting.co.uk and have added a social menu just above the footer.

I’m aiming to use the second link to go to a goole reviews page and ould like to use the standard google symbol as seen here: https://fontawesome.com/icons/google?style=brands

I looked at some previous support requests and found this css:

    .social-links a[href*="google.com"]::before {
      content: '\f0d5';
    } 

which applies the Google + logo “f0d5” and tried replacing f0d5 with f1a0 but it just changes to a blank space with no icon.

Please tell me what else I need to do to be able to use other logos.

Many thanks

Rob

Hi Rob,

Thank you for contacting us.

Try installing and enablin this plugin: https://wordpress.org/plugins/font-awesome/.

Regards,
Kharis
aThemes Support

Hi Kharis,

Thank you for your quick reply. Unfortunately, that doesn’t solve the problem and since installing the plugin as advised, we have lost the icon. I deactivated the plugin but still no icon - not even the original G+ icon.

Is there another solution please?

Many thanks

Rob

Hi Rob,

What is the link to your Google Plus added into your menu? I’d like to try it with my test site since your website is not accessible.

Regards,
Kharis
aThemes Support

The link is actually to our reviews page: https://www.google.com/search?q=peter+skelton+driving+school&rlz=1C1CHBF_en-GBGB928GB929&oq=peter&aqs=chrome.1.69i57j35i39l2j69i59j46i433l2j0i433j46i433.3125j0j15&sourceid=chrome&ie=UTF-8#lrd=0x4876a6375117f971:0xe10b17d8a0196033,1,,, The link was ok when the G+ icon was in place we just needed to change the actual icon to work.

Thanks again and let me know if you need any other info.

Best wishes

Rob

Hi Rob,

Thank you for sharing the link.

You can use this code as you put www on the link.

    .social-links a[href*="www.google.com"]::before {
        content: '\f0d5';
    }

Regards,
Kharis
aThemes Support

Hi Kharis,

I tried that and it restores the G+ logo “fd05” but I want to use the standard G logo “f1a0” which still does not display.

Please help.

Thanks again & kind regards

Rob

Hi Rob,

Seems likely there is something blocking f1a0 with the current Font Awesome script.

The solution for this, you’ll need to enable the Font Awesome plugin.

Then use this CSS code:

    .social-links a[href*="www.google.com"]::before {
      font-family: "Font Awesome 5 Brands";
      content: "\f1a0";
    }

Regards,
Kharis
aThemes Support