Slow Load

Hi,

Lovely theme! Unfortunately, I’m having some very slow load times (http://ecdaproject.org/commons). And Mobile almost never loads at all. After going through threads in your forum on this topic, I’ve tried disabling .preloader, adding cache plugin, and even removed slider altogether–no effect. I am getting several recorded 400 error on loading google fonts (not sure if this is at all related–sorry still learning here).

(I need to persuade my team this is a good fit for us and to put forward funds for “pro,” so I need to make sure the speed issue is not theme specific. The other themes I’ve tested over the past few months have been fine, so I’m pretty sure it’s not my host – at a major university)

Any and all info/help here is greatly appreciated!

Again, fantastic theme!

Best,

Ben

Hi,

Google fonts are not a big deal, you are requesting non-existing ones. If you open link from console http://fonts.googleapis.com/css?family=Source+Sans+Pro:100,100,100 you will get 400 error, and if you open it like this http://fonts.googleapis.com/css?family=Source+Sans+Pro you will see that there is only font weight of 400, so this will work http://fonts.googleapis.com/css?family=Source+Sans+Pro:400,400,400

Bigger problem are script errors. Please disable all your additional plugins and scripts because of possible plugin conflict, and start from scratch, and always check chrome developer tools console for errors.

Another problem can be related to file permissions, so check this guide https://codex.wordpress.org/Changing_File_Permissions

Also you can try to reinstall theme or re-upload it over existing one in order to be sure that every file is in place.

After this, if problems persists, please contact hosting service provider in order to check server error log.

Also you are using PHP 5.3, you should consider using greater version since these are new WP requirements https://wordpress.org/about/requirements/

Lastly, check page speed with this tool https://gtmetrix.com/reports/ecdaproject.org/xeSkbazq your score is poor because of errors and to many requests (because of lot of plugins), and never use caching plugins while developing site, only after development.

Sydney demo site score is this https://gtmetrix.com/reports/demo.athemes.com/14LivLJQ (smaller number of requests)

Hope that you will be able to resolve this.

Best Regards

Update:

I think the slow load was due to a few non-theme related issues (e.g., I had javascript errors that were the result of some enqueue bootstrap code I placed in theme file on initial install – sorry, still learning!). However, a couple of things may be worth noting,

  1. I was receiving a few errors on upload (inspect element) for google fonts. I figured out it was trying to locate fonts/styles included in customizer > fonts, which I had edited. I understand now how/why I did this incorrectly – I had believed that I could make a global type css change to font/style (e.g., change-out font-weights) merely by adding in my own values in customizer fields (because that’s how other themes handle “font” style edits in customizer). There is a note directing users to google font api (which is not informative at all in wp/theme context) and other documentation, but your team might consider noting a bit more explicitly how to use these fields appropriately, at least so they understand (w/o having to follow a link) that these fields are actually setting the call for the google fonts and, therefore, rely on a very strict syntax. (e.g., I see font-weight: 400 and I think, oh, I’ll just change out to 100, which is only dumb if you understand how the fields are being used) Just a thought.

  2. There was a spelling error in the theme file in the following section:

/**
 * Change the excerpt length
 */
function sydney_excerpt_length( $length ) {
  
  $excerpt = get_theme_mod('exc_<strong>lenght</strong>', '55');
  return $excerpt;

}
add_filter( 'excerpt_length', 'sydney_excerpt_length', 999 );

“length” is spelled incorrectly on " ‘exc_lenght’, ‘55’); "

Other than that, I think the slow load is resolved.

Apologies if I wasted anyone’s time here! Really, really love the theme! (fingers crossed, we’ll be sticking with it for our project site!)

Sorry, didn’t see your reply!

Thanks so much for all of your helpful advice! I’m going to request a code review for my project from my university library services based on your feedback and shared resources.

All the best,

Ben

Thanks for update Ben,

We are glad that you have managed to resolve this. If you like our theme, and our support service, please leave a rating https://wordpress.org/themes/sydney/ . Rating are always welcome :slight_smile:

Best Regards