"Skip to content" Button is Hidden by Default

I was about to create my own “Scroll Down to Content” CSS to inject, when I realized there’s actually a, “Skip to content” button already on the frontpage! However, it’s hidden by default. By doing a page search (CTRL+F), if I type “s”, the button automagically shows. However, I cannot get it to show by default otherwise.

I’ve attempted to modify the z-index as well as the visibility properties to no avail. And though I’ll admit I may have missed the switch in the Appearance ==> Customizations, or elsewhere in the settings, I’ve not been able to find a switch anywhere that’ll turn it on. Neither is there anything mentioned in the Moesia documentation.

Not sure if this matters or if it helps: But I’m using a video on the frontpage.

Help! (and thank you!)

Hello Boyd,

I would like to apologize in advance for the long delay. Thank you for your patience.

It isn’t considered as an issue to resolve, as theme which is hosted on WP.org must hide it by default. It has become a WordPress standard for accessibility purpose.

For more comprehensive technical details, read on here.

The below is CSS code which hides it:


.screen-reader-text {
    clip: rect(1px, 1px, 1px, 1px);
    position: absolute !important;
    height: 1px;
    width: 1px;
    overflow: hidden;
}

You can override it in your child theme’s style.css or additional CSS option (Appearance > Customize > Additional CSS).

I hope this clarifies things a bit.

Regards,
Kharis

Awesome! Thanks much! I went to the link and got the code to inject to show by default. You’re the man!

You’re most welcome!

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis