Sidebar widget missing on single post pages

Hi.

There is an option to make the posts full width in the customiser, however my posts are always full width and the sidebar widgets scoot down to the bottom, and I cannot disable this. I want my sidebar widget! Ant ideas?

http://connect.cwb.world/connect/beta-overview/

Hi,

Seems there’s an error there that stops the sidebar from hiding, not sure why atm as I’ve just tested it and it works fine. That’s what that option should do but somehow I think you actually expect it to stretch the content from one screen edge to the other?

Hi Vlad!

I actually want to see the sidebar - I can not make it appear at all. I have removed all sidebar widgets and just added one simple text widget. It doesn’t show on single post pages and gets scooted down to the bottom.

So it does appear but not in the right position. Just disable that option you mentioned from Customize > Blog options > Full width single posts. I’m hoping I understand correctly what you’re asking.

Yes it appears in the wrong position. The problem I have though is that Customize > Blog options > Full width single posts is already disabled. I never enabled it. I have tried enabling it and disabling it - no change!

Actually, to add to the above, I am having general widget issues. The footer widgets were misbehaving so I removed them.

I just became aware my developer license for support expired so I renewed it.

I think you’re building the post with some page builder plugin? Unfortunately that plugin isn’t using the correct template file from the theme.

You can fix it though by adding this in Customize > Additional CSS:


@media ( min-width: 991px ) {
  .single-post .content-area {
    width: 66%;
    float: left;
  }
}

Thanks - that fixed it, except that it also overid the main page which should not have a sidebar with widgets. Could you tell me how to exclude that please?

Sorry about that, I’ve edited the code in my previous post.