Shortcode in same services sometimes work but sometimes don't

Hi

I’m using Codelights Popup and WP Downloadmanager plugins and refer them in 2 services I’ve set up. On one page, where all services are listed (https://illutas.com/en/services/), they work. In the first service (IDEA) there is a reference to a download document, in the second (CIO in a box) there is a popup with a diagram.

However, exactly the same widget, slug etc are used on the front page for the same services https://illutas.com/en/#HomeServices, but there they do not work. Under “Our Services”, IDEA only states the WPDM short code and CIO in a box the CL shortcode.

I compared setups etc but cannot see the difference or why this should be?

Could you help

Hi,

I can only think of two things:

  1. you’re using the Excerpt mode in the widget rather than Full content (which doesn’t seem to be the case);
  2. You haven’t added the shortcodes correctly in your service editor. You either added them in Text mode instead of the Visual mode or you copied them from somewhere and by doing that you also inserted some characters that shouldn’t be there.
    I just tested and shortcodes should work fine.

Hi Vlad

I re-inserted the shortcodes, but with the same result. I also re-inserted the Talon Services widget on the front page, no change. And the problem is that the same widget with the same slug and the same services and exactly the same settings works on one page, and not on the other :frowning:

Any ideas?

Thanks for your help!

Regards

Thomas

Hi,

Send me an admin account please to vlad[at]athemes.com so I can have a look. Not really sure what’s going on there.

It was the Recent Posts Widget Extended plugin that was causing the issue. Probably it was somehow interfering with your shortcodes plugins. I’ve left it disabled now.

Please remember to delete the account you’ve sent for me.

Hi Vlad

Thanks for that. One question: I used this plugin to display the recent posts on the homepage. Any ideas how I could do that differently now?

Thanks!

Regards
Thomas

Hi,

You could use the blog widget from Talon: http://demo.athemes.com/talon-pro/#pg-225-11