Services Widget not showing anymore bc of category slugs

Hi,
I recently updated the website of my client (worpress updates, plugin updates, theme updates)
I also did some perfomance improvement with cache installation (w3), running all the cleaning stuff from wp-optimize (including database cleanup), and trying around which plugins can be deactivated (i also deactivated PageBuilder by SiteOrigin & Sydney Toolbox. But Activated them again afterwards).

Now, the Services Widget on the frontpage “home” is not showing anymore. After some debugging i realized, that the widget works again if i remove the category, in the widget setup in the page editor. Then i tried to assign other categories to the relevant posts (in the Services Section created by the Plugin/Theme) and entered the new categories in the widget setup in the page editor. That did not work. Reassigning the old categories did not work, either. All other options in the widget setup in the page builder (when no category slug is entered) can be edited and the widget stays visible. It’s just about the category slugs (the last input field in the widget setup).

Possible ideas:

  • Some configuration was deleted through wp-optimize?
  • Wordpress Version issues with the Theme/Plugin Version?
    (WP v5.3.2, Sydney Theme v1.57, Sydney Toolbox v1.05 - all up to date as of 5th Jan 2020)
  • Plugin Interferences?
    (I deactivated about half of the installed plugins, including cache, wp-optimize, page builder, … - But still, same error)

Thank you so much for your help!

Hello,

I’ve just tried to recreate your issue on my local Sydney install, but that feature works as it should. So the issue seems to be site-specific. You can try to deactivate all your plugins except Sydney Toolbox and Page Builder by SiteOrigin, and see if it helps.

Kind Regards, Roman.
aThemes Support

Thanks, that helped for debugging. Now i know the problem is not occuring, when Polylang v2.6.8 is deactivated. Since Polylang is an essential plugin in this case, it’s unfortunately still a problem.

Hello,

I don’t think that there is an easy workaround, unfortunately. But you can try to rebuild your website with Elementor according to updated Sydney theme documentation in a staging environment or locally and see if it works as it should (then you will be able to move rebuilt website to production environment).

Please remember about importance of regular full site backups (files and database):
https://wordpress.org/support/article/wordpress-backups/

Here are the helpful tutorials:


Kind Regards, Roman.
aThemes Support

Thanks for your last comment, i appreciate that your team takes time to look into this.

For now i found the following workaround:
Downgrading to Polylang 2.3.2 -> Services Widget Works again
(With WP Rollback)

Greetings

You are welcome!

And thank you for sharing a workaround.

Kind Regards, Roman.
aThemes Support