Services widget does not update

I’ve created several services. Each has an image in the description. I moved the images, then updated the services to correct the image url. The services look fine, and inspection shows they have the correct url for the image. I’ve placed the services widget on Front page and also on Home page. On those pages some of the images do not show up. Inspection shows that an incorrect img url is in the code for those services in the widget. Seems like some changes to services update the widget perfectly, and some don’t register with the widget at all.

I’ve cleared cache and browser several times. I’ve updated the services that aren’t displaying properly several times. I’m baffled, and frustrated.

Here’s one of the service pages: http://jliacademy.org/wp/services/wed-4-5pm/

Here’s the front page where it should appear: http://jliacademy.org/wp

How can I get the widget to update to current version of the services? Please help.

So, I got that one to update. Don’t know how. Just did it over and over and over. That’s not gonna work long term . . . Still haven’t gotten this one to update: http://jliacademy.org/wp/services/friday-4-5-pm/

Hello,

It looks like almost everything works now, except the following image.

Can you please try to re-upload this image?
http://jliacademy.org/wp/wp-content/uploads/2016/08/witch.png

Kind Regards, Roman.

I ultimately resolved this problem 3 months ago by starting over, deleting the services that wouldn’t update and re-creating new services. Obviously this is not workable over long term. Now need to add new services, and same problem. http://www.jliacademy.org/wp/currentclasses/ At this time the Wednesday classes show only the time, although the actual services I’ve created include pictures and text. At this time I can’t get the correctly edited version of Friday 4-5 class to show either. I’ll keep working on this, but could sure use some help.

So, because I need to post this information, I’ve recreated the Wednesday services, and the widget accepted that. Old, not updating, versions have been deleted. I have left the Friday 4-5 service as is – that is, tried to update multiple times but I still have old version showing up in the widget on opening, home and services pages, while the updated version shows here: http://www.jliacademy.org/wp/services/fri-4-5-pm-2/ The update is – I’ve revised the last sentence. Will replace this later in week, but I sure could use some help before I have to go through this long work-around again.

Hello,

Can you please try to deactivate all your plugins except recommended and see if it helps?

Kind Regards, Roman.

Greetings Roman – sorry for delay in responding. Somehow I’m not getting notices of answers on this forum, will try checking in more often. I haven’t actually tried deactivating plugins, because I’m using them. All “say” that they are compatible with Moesia (I know that may not be accurate). I’m using Simple Calendar and MailChimp for some of my primary pages so I don’t want to deactivate. Any other approach?

Hello,

  1. You can click SUBSCRIBE in the blue bar above in order to subscribe to this topic. You can unsubscribe later in the same way, by clicking UNSUBSCRIBE.

  2. You can copy your website to localhost and experiment there. Please remember about importance of regular full site backups.

Kind Regards, Roman.