"Services" stopped showing on my Front Page

Hello,

I have installed all the recommended plugings, widgets and installed the sydney demo. My front page was displaying everything. Now The “Sydney FP: Services Type A and Sydney FP: Services Type B” are not displaying on my front page. The row and widget is there when I go to: Pages> “My front page”. All the content is there in “Services” but not displaying in front page.

Please help!

Here is my url if you need it. http://brushupnc.com.s212785.gridserver.com/

Thank you!

Hello Rosa,

  1. Please go to your Dashboard -> Pages -> edit your front page -> edit Services widget -> make sure that category slug field is empty to show all services, or matches the right category to show only services of certain category.

  2. If #1 doesn’t work, try to deactivate all your plugins except recommended to make sure that there is no plugin conflict.

Please feel free to ask any other questions that you might have.

Kind Regards, Roman.

P. S.
I noticed that the size of your logo is huge, 3245×1636px. That’s way too much for a logo :slight_smile:

Thank you for your help.

-Categorie slug for services match.

-I deactivated all plugins and still no luck.

Hoping to fix this issue soon. Thank you!

Okay Rosa,

Please try to deactivate Sydney FP: Services Type B widget and leave only Sydney FP: Services Type A.

Kind Regards, Roman.

Hi Roman,

Could you please explain how to go about doing that? Or would it be easier to get you access to my dashboard?

Thank you so much for your help!

Well, that’s easy :slight_smile:

Just go to your Dashboard -> Pages -> edit your front page -> find Sydney FP: Services Type B -> click Delete -> click Update.

Kind Regards, Roman.

Okay Rosa,

Please also try to do the following to resolve your issue.

Go to your Dashboard -> Types -> Post Types -> Services -> scroll to Taxonomies to be used with Service section -> uncheck Categories checkbox -> click Save Post Type -> check Categories checkbox again -> click Save Post Type again.

I really hope that it will help you.

Kind Regards, Roman.

Hi Roman,

First of all thank you so much for helping me.

I tried all your suggestions. No luck.

Maybe it has to do with this? I have copy and pasted the following from “Edit Post Type”

Post Type name plural (required)
Services
Post Type name singular (required)
Service
Slug (required)
service

Should the “Slug” be named “Services”? (Plural) When I tried to change it to “Services” it tells me that name has been “already in use or a reserved word. Choose a different slug.”

Please advice.

Thank you Roman! :slight_smile:

Hello Rosa,

Yes, by default the slug is services. I’m not sure why it doesn’t let you change it, but it might be the problem. Did you install some plugins that could potentially interfere with Types plugin?

Kind Regards, Roman.

I only have the recommended plug-ins.

The slug should indeed be plural, otherwise the widgets won’t pull the posts. Try to re-import the settings file. If that doesn’t work send an admin account to vlad[at]athemes.com and I’ll have a look.

Would re-importing the settings files delete my customizations?

Thank you.

Depends what you mean by customizations. If you’ve made changes to the settings initially imported in Types (which I assume you did since services is renamed to service) then yes. It won’t touch code changes or content though.