Service Links

Hi there,

Sorry I have so many questions.

I want to link each of my services to their own page so that I can go into more detail.

I went to pages, and created a new page called “accounting” and under page attributes, I selected the parent to be “services.” The permalink created was http://claxtonconsulting.ca/services/accounting

I then went to Services > Accounting, and put http://claxtonconsulting.ca/services/accounting into the service link box under “service icon.”

But, when I go to my website, and click on either the Accounting service link from the “Services” page, or the Accounting option from the drop down menu under Services on the top right menu, they both go to http://claxtonconsulting.ca/services/accounting2 which is the permalink for Services > Accounting, NOT the permalink for Pages > Accounting.

How can I stop it from going to the wrong link?

I was playing around with the settings in the Types plugin and now my services have disappeared from my site :frowning: Any idea how to fix this?

Hello there,

Maybe permalink conflict occurred once you created a “Services” page.

Try to change the “Services” page’s slug into another, e.g. our-services. Because services slug belongs to the “Services” post type. Then flush permalink: go to Settings > Permalink > just hit the “Save Changes” button.

Regards,
Kharis

OH. MY. GOSH. You are a genius!

It worked!! I searched all over the internet trying to find a solution, but it was so simple!!

Thank you so much!!!