Separate blog for Sydney theme site

Hello! I’m re-building my website using the Sydney template. This forum/support ist amazing and several posts have helped me a lot. But now I have a problem for which I haven’t found an entry yet:

Actually it sounds pretty easy but I can’t work it out:

I would like to create a separte blog on my site (besides normal articles that are displayed on the homepage). A blog with a different posting structure, meaning just one site with posts that show with full content. How do I do this?
I hope you understand what I mean. I have a homepage with slider, below my main articles. In the header I have my menu. There you can click on “Blog”. Now I would like to have (as a target) one site with all my blog entries (not articles on homepage) that show with full content.

Much thank’s for your help.

Chris

Hello Chris,

Firstly create a blank page and enter “Blog” for the title. Publish and ensure it is neither private nor password protected. Then go to Settings > Reading; choose static page on “Your homepage displays” section select your homepage and choose “Blog” page for posts page.

Regards,
Kharis

Hi Kharis,

thank you for your answer and trying to help. I followed your instructions, unfortunately they haven’t worked yet.

  1. The slider on the hompage disappeared when I changed to static.
  2. The “blog” page does show with entries (that have the tag “Blog”) but the layout is the same as on the homepage (masonry and not full content). And I would like to show them vertically (one above the other) and with full content.

Any advice? :slight_smile: Thank’s so much for your troubles.

Chris

Hi Kharis, do you see a solution to my problem?
Thank’s for your help!

Please share a link to your site, so I can have a look.

2

Probably I could suggest you with custom CSS code when I get your site’s link to visit.

Regards,
Kharis

Hello there,

Thank you for sharing.

1

Were you referring to this option located under Appearance > Customize > Header area > Menu Style?

25

This should not hide main main site’s slider. Your is now using Sticky menu. If it’s the issue you’re talking, please enable static menu. Then I can inspect what’s going wrong in there. Let me know if you have more words to explain.

2

I noticed your other blog page is actually blog category archive. By default any posts archive pages will load the same blog layout. To disable grid layout mode on specific category, you would do the following steps:

  1. Install and activate the TC Custom JavaScript plugin
  2. Go To Appearance > Custom JavaScript
  3. Paste the following code into the provided box
    jQuery(function($) {

      var $container = $('.category-blog .post-wrap .posts-layout');
      $('.category-blog #primary').removeClass('masonry-layout');
      $container.imagesLoaded( function() {
        $container.masonry('destroy');
      });

    });
  1. Update

Regards,
Kharis

Kharis, thank’s for your answer. Unfortunately I can’t get the articles shown on the homepage despite doing everything according to your instructions. The blog posts will show but on the home page I just get a blank section that says Home. I created a new site (Home), labbeled it as Homepage, then labbeled articles I want to show on Home page as “Home”, but they won’t show on Homepage… It’s just a blank page…No idea what I’m doing wrong here… Thank’s for your patience…

I probably have found a solution: the plugin “Wordpress Hide Posts”, then, when editing new post choose “hide on front page” for all entries that you only want to have on the blog site…

Kharis, so there are only two problems left - maybe you have solutions :slight_smile:

  1. Take a look here: https://www.dietiefe.com/category/die-ufo-studien-des-pentagon/
    Is it possible to get title and introductory text in line with images/texts of posts (margin left not the same)?

  2. Take a look here: https://www.dietiefe.com/category/blog/
    Do you see a possibility to show all posts on this site (only here, in blog section) with full content?

Hello there,

I visited your link and it seems like your site is now unavailable for public access. Is there any other way that allows me to check it?

Regards,
Kharis

Kharis, thx for your answer— it should show now! Greetings Chris

Hello there,

1

I saw they’re correctly alligned now.

Or did I miss anything?

2

From your site’s dashboard, go to Appearance > Customize > Blog options; under " Content/excerpt" section, click on the option that reads “Check this box to display the full content of your posts on all archives.”

Regards,
Kharis

Thanks, Kharis, but I probably didn’t explain good enough…

  1. I mean aligning this “Die UFO-Studien des Pentagon
    Die Geschichte der Skinwalker-Ranch klingt wie der Plot für eine klischeebeladene Science-Fiction-Fernsehserie. Wohl die meisten Menschen würden nie glauben, dass sie wahr sein könnte. Was ist wahr? Und in welchem Zusammenhang steht die Ranch mit dem UFO-Forschungsprogramm des Pentagon, das die «New York Times» enthüllte?”

with the other elements (left margin not the same)…

  1. Yeah, but that will change the layout in the “Dossier” section as well…

1

Try adding this CSS code to Appearance > Customize > Additional CSS from dashboard.

    .masonry-layout .posts-layout {
      margin-left: -15px;
      margin-right: -15px;
    }

Yeah, but that will change the layout in the “Dossier” section as well…

When this option remains enabled. Add the below code snippet to a child theme’s functions.

    add_filter( 'theme_mod_full_content_archives', 'sydney_child_set_full_content_on_blog_archive' );
    function sydney_child_set_full_content_on_blog_archive() {

      if ( is_category( 'blog' ) ) {
        return true;
      } else {
        return false;
      }

    }

If you don’t have any active child theme, you could use a plugin that does same purpose like Code Snippets.

Regards,
Kharis