Select Dropdown fails to load properly

Hello. I believe that this Dropdown styling is from the Airi theme and I like it very much. Right now it is used in a filter by attribute widget. But the problem is that the CSS fails to load on page and there is a weird half a second change, that is very noticeable and distasteful. ( uploaded a gif )

Any ideas how to fix this? Thank you.

Is there a way to disable this default theme styling for select dropdown?

Hello,

I would be glad to help you, but can you please provide a link to your website first in order to let me check it? You can use some link shortener if you don’t want to leave the link to your site in this topic.

Kind Regards, Roman.
aThemes Support

https://bit.ly/3daApOl
It’s this specific page that you can see the problem on.

Yes. Thank you. If possible I would like to disable the theme styling and do it myself via custom CSS because it seems to work fine that way.

Thank you.

Hello, and thank you for the link.

You can try to use a preloader plugin.

For example the Preloader or LoftLoader.

Kind Regards, Roman.
aThemes Support

Thank you. I will try that. But is it possible to disable it altogheter?

Hello,

But is it possible to disable it altogheter?

I don’t think that there is an easy way to do it, unfortunately.

Kind Regards, Roman.
aThemes Support

I understand. Thank you. I shall use the preloader.

OK, you are welcome!

Please feel free to ask any other questions that you might have in future.

Kind Regards, Roman.
aThemes Support