Search in main navigation sydney pro

I’ve added I’ve added <?php get_search_form(); ?> in header.php and
css:

#mainnav {
  float: left;
}
.header-wrap .search-field {
  height: 30px;
  padding: 5px 15px;
}
.header-wrap .search-submit {
  display: none;
}

I tried doing this in the newest version of Sydney Pro http://p00.2b2.myftpupload.com/

As you can see the search lies below the header. I would like it to be in the Nav, next to Blog.

Please advise ASAP
Thx
Robert

Hello Robert,

I’ve added I’ve added <?php get_search_form(); ?> in header.php

I’m not sure where exactly you added that code within header.php file, but you can try to replace this line:

<?php wp_nav_menu( array( 'theme_location' => 'primary', 'fallback_cb' => 'sydney_menu_fallback' ) ); ?>

…with this:

<?php wp_nav_menu( array( 'theme_location' => 'primary', 'fallback_cb' => 'sydney_menu_fallback' ) ); get_search_form(); ?>

…and add this CSS code in the Customize → Additional CSS section:

#masthead .search-form .search-field {
    height: 34px;
    width: 160px;
    padding: 5px 10px;
    border-radius: 3px;
}

#masthead .search-form .search-submit {
    padding: 4px 12px;
    bottom: 2px;
}

#masthead .search-form label {
    margin-bottom: 0;
}

#masthead .search-form {
    display: inline-block;
    padding: 2px 4px;
}

#masthead .mainnav > div {
    display: inline-block;
}

Kind Regards, Roman.
aThemes Support

Thank you, that worked like a charm.

On another note, I would like the links on this page to be black after they have been visited.

Similarly with this Products widget, in addition, I would like the red (#e64e4e) on hover also

Please advise
Best
Robert

I tried this for the widget but its not working:
/* visited link */
#textwidget, a:visited {
color: #000000;
}

/* mouse over link */
#textwidget, a:hover {
color: ##e64e4e;
}

Hello Robert, you are welcome!

Can you please create a separate topic for each of your additional issues in order to make it easier to help you?

Kind Regards, Roman.
aThemes Support