Search Icon in contact info header

Hello,

I try to accomplish a search icon in header and follwed this

solution. Everything worked quite fine, just that would like to have the search bar in the contact info header on the right side.
Which would be the right way to do so?

Thanks a lot in advance.

Regrds
Kruna

Hello and sorry, I found already the solution,

change

    if ($args->theme_location == 'primary') {

to

    if ($args->theme_location == 'social') {

thanks anyway and regards,
kruna

1 Like

Hi again,

tehre is still one little question left.

How can I position the glass icon a little bit down, so that it is in line qith the social icons.

Regards
Kruna

Great! You found the solution. And thank you for sharing it here.

Can you share a link to your site, so I can inspect your current setup and start with it to find out the solution easier?

Regards,
Kharis
aThemes Support

Hi Kharis,

sure the link as follows

TY and regards
kruna

Hi Kharis,

thank you very much for your effort, I really appreciate all your help.
I found the solution by learning by doing inspecting my site.
Adding the bold line in CSS

    .top-search-menu label:before {
      font-size: 13px;  
      width: 20px;
      height: 20px;  
     **margin-top: 3px;**
    }  

did it.

TY and regards,
Kruna

1 Like

You’re welcome Kruna!

Glad to know you found the solution.

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis
aThemes Support

Hello Kharis,

I hope I didnt mess up something, but suddenly the search icon and social media icons in contact info header are gone!
I cant remeber that I did changes lately and checking the function.php etc. everything is like before.

When I hover over where the search icon and social icons supposed to be, I can see some links like in header menu.

Do you have an idea if or what I did wrong? Can you please help me?

Thanks a lot in advanced
Reagrds
Kruna

Hi Kruna,

As checked, you’re currently running a child theme. Perhaps you’re getting script conflict with it since we have made some major updates on the latest versions of Sydney Pro.

Can you share your child theme to kharis@athemes.com to allow try and inspect the trouble in it?

Regards,
Kharis
aThemes Support