Rocked Theme - updating to PHP 7.2

Hi there aThemes, I would like to update to the latest PHP version as I have an error message in the admin dashboard saying the version is out of date. I have run the PHP Compatibility Checker plugin and it is showing errors with the Rocked Theme.

Are you able to tell me if this is compatible with PHP 7.2 and if not whether you are going to update the theme please?

Many thanks as always

Bibs

Hello Bibs,

I have just used that plugin on my local Rocked install and there are no errors, only warnings about deprecated constructor in widget files. It should work as it is now, but that should be resolved in a future theme version. Please feel free to ask any other questions that you might have.

Kind Regards, Roman.

Hi Roman

Many thanks for checking this out for me. I have subsequently updated and the site looks fine.

Thanks as always

Bibs

You are welcome Bibs!

And have a nice day :slight_smile:

Kind Regards, Roman.

Hello,

Thanks for your messages.
So how can we update our site to PHP 7.2 ?

I am not able to update to WordPress 5.2.1 due to old and uncompatible PHP version.

Thanks a lot

Hello,

It’s not a theme issue, please check this page:
https://wordpress.org/support/update-php/

Kind Regards, Roman.
aThemes Support