Revolution slider not working since update


#1

moesia pro
website: http://sisonke-webdesign.at/

Hi Vlad, i have updated the revolution slider as indicated in your guidelines… via ftp - exporting my slides, deleting and reinstalling revolution slider and importing my slides again - but now i cannot edit the slides anymore…
it works with another theme i am working on, but not on the moesia pro. also i noticed with moesia i got revolution slider version 5.0.6. while at the other theme it is 5.0.9. and there it is working
please help, this is my own website and it is not good if the slider on my frontpage does not work as it should…
thanks
caro


#2

Hi,

Not sure I follow. You can’t edit the slides while using Moesia but you can edit them while using the other theme? It doesn’t look like you’ve installed the 5.09 version that the other theme provides. We will be updating the version ourselves though.


#3

Hi,
www.sisonke-webdesign.at is my site built with moesia pro. it starts with revolution slider on the frontpage. after the update following your guidelines, the slider still shows, but it has lost some features. Links for example. Also i want to edit the slider by deleting a slide. but i cannot edit, the editing functions are not active in the backend - i cannot change background color of the slides, put links,nothing. i tried inserting a new slider by importing a template, i can import it, but also not edit it.

at the same time i am using the revolution slider in another site that i designed with another theme www.lorirosenberg.at . as the slider works there, i checked the versions and noticed that it uses 5.09 while moesia pro uses 5.06.

maybe there is some bug in the 5.06?? i need to fix the slider in my website though, it is the first thing my customers see and it doesnt work properly. will you update moesia pro with the 5.09 now or could you mail me the zip of the slider?

thanks…


#4

just wanted to mention, i have copied the 5.09 and inserted into the plugins folder of the website created with moesia pro. now i have the latest revolution slider version, but it has not solved the problem. i can still not edit the sliders…


#5

Yeah. we’ll be updating the slider today. Obviously, this will not solve your problem as you already installed 5.09.
I’m thinking that it might be a plugin conflict between Revolution and something else. Try disabling some of your plugins.
5.06 works perfectly fine on my end, with Moesia Pro active or without it as it doesn’t really matter.


#6

Hi again, am back at 5.06 as i think it will work better when i update through your update. but i just delete and reinstalled revo slider and it is still at 5.06. Didnt you update to 5.09?
i have tried the other plugins, but havent found on yet that would cause the problem, i will still look at this.

i got an error message though as i had change the header rev php before on your advice and it had worked well

(copy header-rev.php in your child theme and look for this code:
<?php $alias = get_theme_mod(‘rev_alias’); ?>
<?php if ($alias) : ?>
<?php putRevSlider($alias) ?>
<?php endif; ?>
Replace it with this and add your aliases:

<?php if ( wp_is_mobile() ) : ?>
<?php putRevSlider(“youraliasformobile”) ?>
<?php else : ?>
<?php putRevSlider(“youraliasfordesktop”) ?>
<?php endif; ?>
END OF QUOTE


#7

sorry, didnt mean to send the previous message yet…

so the error message was about this, so i deleted the header rev php in the child theme just to see if this caused the problem. but now i get another error message:
[08-Oct-2015 20:44:38 UTC] PHP Fatal error: Call to undefined function putRevSlider() in /home/sisonked/public_html/sisonke-webdesign.at/wp-content/themes/moesia-pro/header-rev.php on line 79

this is the whole snippet: line 79 would be <?php putRevSlider($alias) ?>
is there an
<?php endif; ?>
too many? as there are 2…

quote
<?php else : ?>
<header id=“masthead” class=“site-header has-rev” role=“banner”>
<?php tha_header_top(); ?>
<?php $alias = get_theme_mod(‘rev_alias’); ?>
<?php if ($alias) : ?>
<?php putRevSlider($alias) ?>
<?php endif; ?>
<?php endif; ?>
unquote


#8

Hi,

We haven’t updated yet to 5.09, but that won’t probably solve the problem. Otherwise it would have worked already with the 5.09 you already installed.

There aren’t too many endif; as one is for code that starts before your code.
If putRevSlider throws an undefined error then it’s because Revolution Slider was disable at that time when you checked. Can you confirm?


#9

Hi, i finally found the source of the problem… this is what caused it - in the functions php of the child theme:
/**

  • defer js parsing for speed
    */
    function defer_parsing_of_js ( $url ) {
    if ( FALSE === strpos( $url, ‘.js’ ) ) return $url;
    if ( strpos( $url, ‘jquery.js’ ) ) return $url;
    return "$url’ defer ";
    }
    add_filter( ‘clean_url’, ‘defer_parsing_of_js’, 11, 1 );

so, thanks a lot… all perfect as usual…


#10

Hi Vlad,
i am back again… with the deletion of the snippet in the child functions php i managed to edit the revo slider again, but it still does not work properly. But only on the frontpage (homepage).
the same slider on a testpage (with the template frontpage) works well.
http://sisonke-webdesign.at/test1/

some animated elements do not work, they should only be visible for a certain time, but after the slide has looped a few times, the animation is broken. i also tried with an imported slider of themepunch and it also does not work properly on my homepage, but it works on a test page.

I have tried to find the solution, i removed the header php of the child theme with the google analytics script, but it didnt help. the only thing i have in the child functions php is:
quote
<?php
/**

  • shows in blog only posts with category blogt
    */
    function my_home_category( $query ) {
    if ( $query->is_home() && $query->is_main_query() ) {
    $query->set( ‘cat’, ‘14’);
    }
    }
    add_action( ‘pre_get_posts’, ‘my_home_category’ );
    unquote

but that does not influence the homepage… there must be something conflicting on the homepage, but i cannot find it…

It would be so great if you could advise what the problem would be… thanks a lot.

screenshot of the broken animation on homepage:
http://sisonke-webdesign.at/?attachment_id=1145

screenshot of broken animation of themepunch example slider on my homepage:
http://sisonke-webdesign.at/?attachment_id=1143

screenshot of animation of thempunch example slider on testpage:
http://sisonke-webdesign.at/?attachment_id=1144


#11

Nope, there’s no way that happens :slight_smile: I’m looking at it now in Chrome and Firefox and I don’t see what you have in your screenshots. Clear your cache please and retry. Let me know how it goes.


#12

Here’s a screenshot of what I’m seeing in Firefox. I noticed you also use FF in your screenshots: http://snag.gy/W2u62.jpg


#13

Hi, thanks for coming back.
it happens in firefox and chrome when it loops the 4th or the 5th time, then for sure, sometimes earlier. i cleared the cache before already to see if this was the problem, but it didnt solve it.
for you to see, i installed the revo slider in question at the end of the frontpage, there you can see it easier, just let it loop a few times and it will get mixed up again. definitely at the 5th time.
on the other side on the testpage http://sisonke-webdesign.at/test1/ it always works. it can loop endlessly.
this is how i came to think that it has something to do with the homepage…


#14

Yeah, I see what you mean now. But is it happening in the header for you? For me it looks right in the header, no matter how many times it loops. The issue shows only with the bottom slider.
Thing is that we don’t do stuff in the theme that are tied to the actual homepage, we do them tied to the Front Page template. It’s strange because you’re using the Front Page template on both pages and it works fine on the other one.
Anyway, export your slider please and send it to me at vlad[at]athemes.com so I can test it.


#15

just after you wrote, i tried and it looked right in the header too. but now i tried again and in ff, chrome, explorer - in all it didnt work in the header, in a very irregular manner: in ff it didnt work the 1st time, the second, 4, 7 - it did work the 3rd time, 5 and 6. I think this is random.
at the bottom slider it is always the 4th or the 5th time it starts not working. the test1 page it always works.
i ll send you the slider now on your email.
so, if it doesnt work on the homepage, but you tie things to the front page template, then it relates to some stuff in the header??
the only files i have in the child theme are functions php, style, header
i ll send them to you
and then maybe the htaccess?? i ll send this one too