Reviews not visible in woocommerce


Unfortunately the reviews are not visible on the single productpages.

I have manually updates the template files and switch off and on the review options both with no result.

There is a bleu review link on the bottom of the page but nothing happens when you click it.

One of the products

Thank you for your help.


You have reviews activated from WooCommerce settings? The Reviews link was added by you or that was from WooCommerce?

Best Regards,


It looks like you’re missing a bit of code and that means you’re not using the latest version. Could you please go to Appearance > Themes and check for the update notice?

Thank you guy’s for the fast reply.

Csaba: Yes I have the reviews activated in WooCommerce by product date > advanced. When I activate reviews the link will be visible on the single product page. When I deactivate the reviews option the link won’t show.

Vlad: you are right and I have updated WooCommerce now with no visible change.

Any other options?

Have a nice evening

Sorry, I meant go to Appearance > Themes and update the theme. Once you do make sure you also clear the cache from your caching plugin.

Themes where/are up to date and cache is cleared. I do work with a child theme of Moesia Pro. Can that be the problem?

It can be if you’re overwriting the scripts and thus not running the latest version. You can switch for a bit to the parent theme to test.

Could you please disable your caching plugin a bit so I can check the files properly (after you switch back to your child theme)?

I’m now using the parent theme and switched off the caching plugin

Now result, i just switched back to the child theme. Catching is still off.

That’s odd. Send me an email at vlad[at] please and I’ll send you the theme so you can re-install it.
Something might have went wrong when you last updated the theme because one of your Javascript files doesn’t have the latest code. Or if you know your way around FTP I can just send you that file so you can replace it. Let me know.

Thank you Vlad and I will send yo the e-mail