Responsive not working

Really loving this theme, but I can’t figure out why it’s not being responsive on mobile devices.
ediblecrush.com

Hello there,

Your site is responsive. You can check it on Google’s mobile friendly tester.

I guess you are talking about the main slide image which is cropped on the smaller screen. If so, please refer to this thread. Hopefully you can get a solution on there.

Regards,
Kharis

Hi Kharis, thank you for the reply and assistance. Really appreciate it.

All though the tester rates it as “mobile friendly” take a look at the preview. The menu, text, and buttons are not resizing for mobile device. Everything is small.

The main slider image being cropped is not an issue.

Hello there,

Could you please take a screenshot illustrating the trouble? For the image files, share them to the free file hosting service like Google Drive, Dropbox, or cloudup.io. Then post its public links here, so I can check.

Regards,
Kharis

Greetings,

Here is a screenshot:

You can also use the Google Tester, it looks the same.

Thank you

Hello there,

Thank you for sharing the screenshot. It really helped me. Try adding the following custom CSS code into your site’s additional CSS option under Appearance > Customize > Additional CSS.


@media only screen and (min-width:768px) and (max-width:1024px){
  
  .header-wrap .col-md-8{
    width: calc(100% + 30px);
    width: -webkit-calc(100% + 30px);
    width: -moz-calc(100% + 30px);
    margin-left: -15px;
    margin-top: -10px;
  }
  
  .btn-menu{
    margin-right: 20px;
    margin-top: -30px;
  }
  
}

Let me know how it does anything.

Regards,
Kharis

Greetings,

Thank you for the code, but it seems to have no effect.

Note: the mobile preview in “Customize” looks correct. Before and after your code correction. But in google tester and/or on my device it is not mobile friendly.

Hello there,

Try to clear your web browser’s cache and reload your site.

Let me know how it goes.

Regards,
Kharis

Greetings,

Iphone5 Chrome browser cache cleared. Still the same problem.

You can verify in the preview here:
https://search.google.com/search-console/mobile-friendly?id=hMm7y2oOD8qQL1vF1lWPQA

Hello there,

Please try to use other network. There might be network cache applies.

Regards,
Kharis

Greetings,

I’m sorry. What do you mean other network?

Is it showing as responsive for you??? It is not responsive on our phones or in google tester. Is it responsive for you?

Thank you

Some networks (ISP) applies a cache. You can read more about it on Wikipedia.

I tested it on Chrome’s mobile emulator.

Regards,
Kharis

Tested on multiple different persons mobile phones. All the same problem.