Remove "Leave a reply…Enter your comment here" section at bottom of the page

I tried turning off anything that would keep the “Leave a reply…” section that is appearing on all new pages I create. I can’t seem to find a way to turn if off. Any suggestions?

Here is the link to my site:
http://www.autobodydetailservice.com/public_html/wp/

Thanks!

You probably have them enabled on single pages. If you don’t see a Discussion metabox when you edit your page, then click on Screen Options from the top-right corner and make sure Discussion is checked. Then go below your post editor and see the discussion metabox and make sure Allow Comments is unchecked. This doesn’t have much to do with the theme.

Found it. Thanks! Sorry, rookie Wordpress user here!

Mark